Arm Mbed OS support forum

MAX32625PICO daplink drive issue

Hello,

I am not able to figure out why windows is not recognizing the daplink drive. It does not show up at all. When I opened the create and format hard disk drive partitions, I figured out that windows is asking me to initialize it everytime (shown below)

GPT does not work, so I initialized it as MBR and it still says the following

However, it shows up under device manager (shown below)

image

But it still does not show up as an accesesible drive such as the MAINTAINANCE drive.

How do I fix this issue?

Hello,

I do not have this hardware but I saw this old page DAPLink bootloader update | Mbed section How to update your boards

BR, Jan

Hello Johnny,

I tried the tutotrial. Looks like it is not working. I do not have an external debug probe. Is there any other way to get this to work?

My point was to help you determine in which state your board currently is. According to the guide what I shared above.
So if you determined your board is in a bricked state, then is probably no other way to do it.

BR, Jan

Understood. It does look like it’s in the bricked state. What is the reason for that? Also, I am still able to program the MAX32666 MCU using Eclipse IDE, but I am guessing that is happening through DAP since the status LED blinks green while programming. Even if it can program through DAP does it mean that it can still be bricked?

Here you can find different firmwares for that board, you have to choose depending on which MCU you are about to program with. If you have a second MAX32625PICO board you can try to upload max32625pico_max32625pico.bin to your problematic board over the second one. That should help if your pico just can not go into maintenance mode for some reason but is still not bricked. However if also this does not help, then chances are high it is not recoverable anymore.

I am able to do it in Linux! Both the maintainance and daplink drives are visible in Linux. Looks like this is a windows issue now. What could be the potential reasons it could fail in windows?

That is interesting as i work on windows only and never faced the issue with my MAX32625PICOs you described. So hard to tell what could have caused it, but luckily it does not mean the board is bricked.

Did you tried to uninstall driver of that device (via device manager)? Windows will install it again after reconnect.
Alternatively you can compare your driver (name, version) with Peter’s driver.

BR, Jan

Hey, that worked like a charm! Initially when I uninstalled the drivers and plugged it in it showed the DAPLINK drive. But I could not get it to go into MAINTAINANCE drive at all. So this time, I uninstalled the driver and then directly made it to go to MAINTAINANCE drive. And after that it started showing DAPLINK and MAINTAINANCE drives properly! Thanks a lot!

I am glad I could help but it is good joke :smiley:
I experienced it at work with a printer. It was caused by a Win10 update what corrupted the printer driver.

BR, Jan

Ohh :joy: Yeah, more often than not windows update breaks drivers