Mbed-client-examples can NOT finish DHCP with mbed-drivers version v0.11.6

(Nick Zhou) #1

Hi ,

I am trying to run mbed-client-examples. It worked for me last week.
I tried to do "yotta update" today and find that it stops working. The only log is:
IP address

It seems that the FRDMK64F board can not get IP correctly.
Then I tried to reverse the mbed-drivers back to version v0.11.4 and it works. It can show:
IP address xx.xxx.xx.xx


Could you please check why latest mbed-drivers v0.11.6 makes mbed-client-examples not working?


(Mary Jane) #2

Hi. It's the same with v0.11.8.
I have 25 FRDM-K64F boards and some of them work and some not.
All of them have the same board revision and bootloader version.

(Yogesh Pande) #3

We are working on fixing this issue, its mainly on underlying layer. We will soon be releasing the patch to fix this issue.


(Yogesh Pande) #4

There is a fix for the issue which is released last week so if you update your sources and build again, it should now work fine.


(Nick Zhou) #5

Hi Yogesh,

It works. Thank you very much!

Best regards,

Important Information for this Arm website

This site uses cookies to store information on your computer. By continuing to use our site, you consent to our cookies. If you are not happy with the use of these cookies, please review our Cookie Policy to learn how they can be disabled. By disabling cookies, some features of the site will not work.