Arm Mbed OS support forum

Mesh (Thread) Issues

I had tried the mbed-os-example-mesh-minimal example sometime last year. It had worked fine back then - I had copied settings from the configs folder to update the mbed_app.json file to make the target connect to the mesh network on boot. I then happened to shelve the project for a while.

Now that I have picked up the example code again, I am unable to get a proper mesh connection for the hardware. The device boots up fine. Gets an IPv6 address after connection. However, when I do a discovery scan from another device (in this case, I am using a OpenThread Border Router and OpenThread RCP), I see blank Network Name and blank Extended PAN ID.

Can someone please point me in the right direction? Has something changed with regards to the mesh connectivity API?

Thanks,
Vijay

Hello,

If you want to help from someone else, usually is good to share some links of exact examples what did you tried. What a board do you use, and so on.
You said “last year”. If you have an idea about how long ago. Then you can estimate a version of MbedOS from that time. Then downgrade the MbedOS and you will see a result.

You can also check a history of Mesh on github - mbed-os/connectivity/nanostack/mbed-mesh-api at master · ARMmbed/mbed-os (github.com)

BR, Jan

Hi Jan,

Thanks for your pointers. You are right, some more information would help others help me; I didn’t quite know where to start with the question and that’s why the lack of information in my post. Apologies.

So to improve the details in my initial post, around July 2020, I tried the mesh-minimal example in the Version 5.15 of Mbed OS. I used the thread config json file from the configs folder and adapted the mbed_app.json to make a Silicon Labs Thunderboard Sense 2 work. We then continued using the same set of APIs for developing our project and it worked well up until April 2021, when we stalled the project.

This month, in Nov 2021, I retried the same example code mesh-minimal with the same Version 5.15 and the same settings from the thread config json file on the same Silicon Labs Thunderboard Sense 2. While the code executes, I am unable to get the Network Name and Extended PAN ID in any network scans from other Thread devices. The network name comes out as blank and the Extended PAN ID comes out as 0000000000000000.

Could this be a change in a default setting related to discoverability?

Thanks,
Vijay