Mbed Studio can't debug

I use NUCLEO-F767ZI, can complie ,build . but mbed studio prompt "the detected device ‘usb composite device’ does not support debugging.Debug functionality has been disabled "
how to solve this problem?

1 Like

%E5%BE%AE%E4%BF%A1%E5%9B%BE%E7%89%87_20190331132124 %E5%BE%AE%E4%BF%A1%E5%9B%BE%E7%89%87_20190331132138

Same question, I tried it with the F767ZI, with the L432KC, and I did with the K64F and every board gave me the same issue.

I have the same issue with my F767ZI… it is possible that this board is not yet fully supported, as I was not able to find it on the supported boards list:
https://os.mbed.com/docs/mbed-studio/0.5/introduction/system-requirements.html#supported-targets

edit: I have updated the STLink firmware of the board and it is still not working :frowning:
Hopefully they will fix this issue…

Hi,
I have the same problem with NUCLEO-L152RE, How did you solve the problem please.

Thanks for your interest in Mbed Studio.

We don’t currently support all targets for debugging and the NUCLEO F7* series isn’t yet supported.
We are working on adding more debug support as well as new features and fixes.
Please use the feedback in Mbed Studio to highlight features you would like adding (including debug support) to help us prioritise upcoming work.

In the meantime, the boards pages on mbed.com will outline the debuggable boards. We’ll update this list for each release.

Kind regards,

Rob

Greetings!
The great news is Mbed Studio 0.8.0 supports debugging NUCLEO-F767ZI.
Regretfully though, all I could get is this message:

Selected port 50000 for debugging
0000496:INFO:board:Target type is stm32f767zi
0000501:INFO:coresight_target:Asserting reset prior to connect
0000504:INFO:dap:DP IDR = 0x5ba02477 (v2 rev5)
0000513:INFO:ap:AP#0 IDR = 0x74770001 (AHB-AP var0 rev7)
0000529:INFO:rom_table:AP#0 ROM table #0 @ 0xe00fd000 (designer=020 part=451)
0000534:INFO:rom_table:[0]
0000534:INFO:rom_table:  AP#0 ROM table #1 @ 0xe00fe000 (designer=43b part=4c8)
0000539:INFO:rom_table:  [0]
0000540:INFO:rom_table:    AP#0 ROM table #2 @ 0xe00ff000 (designer=43b part=4c7)
0000554:ERROR:ap:Transfer error while reading AP#0 ROM table: SWD/JTAG Transfer Fault @ 0xe000efbc-0xe000f043
0000579:CRITICAL:__main__:No cores were discovered!
Traceback (most recent call last):
  File "c:\Users\User1\AppData\Local\Mbed Studio\mbed-studio-tools\python\lib\site-packages\pyocd\__main__.py", line 343, in run
    self._COMMANDS[self._args.cmd](self)
  File "c:\Users\User1\AppData\Local\Mbed Studio\mbed-studio-tools\python\lib\site-packages\pyocd\__main__.py", line 571, in do_gdbserver
    with session:
  File "c:\Users\User1\AppData\Local\Mbed Studio\mbed-studio-tools\python\lib\site-packages\pyocd\core\session.py", line 287, in __enter__
    self.open()
  File "c:\Users\User1\AppData\Local\Mbed Studio\mbed-studio-tools\python\lib\site-packages\pyocd\core\session.py", line 367, in open
    self._board.init()
  File "c:\Users\User1\AppData\Local\Mbed Studio\mbed-studio-tools\python\lib\site-packages\pyocd\board\board.py", line 83, in init
    self.target.init()
  File "c:\Users\User1\AppData\Local\Mbed Studio\mbed-studio-tools\python\lib\site-packages\pyocd\core\coresight_target.py", line 164, in init
    seq.invoke()
  File "c:\Users\User1\AppData\Local\Mbed Studio\mbed-studio-tools\python\lib\site-packages\pyocd\utility\sequencer.py", line 208, in invoke
    resultSequence = call()
  File "c:\Users\User1\AppData\Local\Mbed Studio\mbed-studio-tools\python\lib\site-packages\pyocd\core\coresight_target.py", line 298, in check_for_cores
    raise exceptions.DebugError("No cores were discovered!")
DebugError: No cores were discovered!
"GDB server stopped unexpectedly with exit code 1"

Any idea what could go wrong?
I’d appreciate any suggestion,
George.

Ahoj,

I found this, so probably It is a bug and we must be patient.


F767ZI is affected too.

BR, Jan

1 Like