Mbed forum

Missing depedencies when running yotta on stm32f4nucleo

(Charles Armstrap) #1

Machine: Ubuntu 14.04 64-bit

Problem 1:
Running yotta install mbed-drivers on an stm32f4nucleo board gives errors.

Short Version:

armstrap@ubuntu-xps:~/Projects$ mkdir blinky
armstrap@ubuntu-xps:~/Projects$ cd blinky
armstrap@ubuntu-xps:~/Projects/blinky$ yotta init
armstrap@ubuntu-xps:~/Projects/blinky$ yotta target st-nucleo-f401re-gcc
armstrap@ubuntu-xps:~/Projects/blinky$ yotta install mbed-drivers
ERROR

Long Version [1]:

[1] Sorry for uploading a picture. The site won’t allow the plain text to be copy-pasted because it has links in it and it thinks I’m spamming the site. I had to convert the output to an image as a workaround.

(Martin Kojtal) #2

Hello,

I believe this was already mentioned here, here’s a list of targets which are functional: http://www.mbed.com/en/development/hardware/boards/

The target st-nucleo-f401re-gcc is not fully supported yet.

(Ja Yot) #3

yeah this happen to me too under fedora 22. I wonder when this board will be supported ?

(Martin Kojtal) #4

@jayot There was a community driven port, yet not made it to master