Getting started with yotta


(Dan Ros) #1

Discuss getting started with yotta

(Blackstone Engineering) #2

A great place to start is !

(Stephen Paulger) #3 is the address to use now.

(Josh Young) #4

Having some trouble confirming my compiler is working. When I try to run arm-none-eabi-gcc it is failing in my windows cmd prompt. I have installed Cmake and ninja, and have Python 2.7.10 (Docs call for Python 2.7.9, but I don't see why Python 2.7.10 would not work). It seems like yotta installed fine, but I am concerned my compiler is not responding. I made sure to point my path to the compiler bin folder, but no luck running the program. Anyone get this far yet? Running windows 8 64 bit here.

(sam mottley) #5

I can say that I have successfully installed Yotta (using the automated py script) on Windows 8 64 bit.

Yotta is freekin awesome its pretty much identical in function to Composer (PHP dependence manager) which is a compliment as composer is amazing!

Hopefully the Yotta site ( will allow people to add their own packages soon like packagist (PHP

My only complaint would be that Yotta required Python.

Personally I think I'm going to create a Vagrant development environment so I don't have to install all Yotta's dependants on my local machine.

If any of you guys want me to make a video on installing Yotta that's not a problem just give us a shout :smile:

(Stephen Paulger) #6

Hopefully there will be similar videos for windows soon.

(Paul Hey) #7

I'm having issues with the stock example listed here:

I am attempting to compile from Windows. When I get to the build stage for either the application from scratch or the clone-from-repo one, it fails at [9/130] and precedes with the following error:

C:/path/to/example-mbedos-blinky/yotta_modules/mbed-hal-ksdk-mcu/mbed-hal-ksdk-mcu/objects.h:22:22: fatal error: PinNames.h: No such file or directory

Any thoughts? I can provide my build tools versions as well.

(Martin Kojtal) #8

@Androidian072, I created tracking issue, thanks for reporting, I noticed similar issue in another repository.

(Paul Hey) #9

I ran yotta update on the example and it compiles now. It did complain about something not meeting the specification required by minar, but that seems to be a separate issue.

(Sam Kent) #10

Having a similar issue when building, with the compilation terminating as it cannot find these headers..

#include "uvisor-lib/uvisor-lib.h"
#include "uvisor-lib/uvisor-lib.h"
#include "cmsis-core/cmsis_nvic.h"
#include "uvisor-lib/uvisor-lib.h"
#include "mbed-alloc/ualloc.h"
#include "mbed-alloc/ualloc.h"

Any ideas what could be wrong?

 [8/128] Building C object ym/ualloc/source/CMakeFiles/ualloc.dir/ualloc.c.o
error: command ['ninja'] failed
FAILED: C:\PROGRA~2\GNUTOO~1\4636A~1.920\bin\AR10B2~1.EXE   -fno-exceptions -fno-unwind-tables -ffunction-sections -fdata-sections -Wall -Wextra -fno-rtti -fno-threadsafe-statics -mcpu=cortex-m4 -mthumb -D__thumb2__ -Os -g -gdwarf-3 -DNDEBUG   -DTOOLCHAIN_GCC -DTOOLCHAIN_GCC_ARM -DMBED_OPERATORS -DCPU_MK64FN1M0VMD12 -DTARGET_K64F -include "C:/Users/user/workspace/Blinky/build/frdm-k64f-gcc/yotta_config.h" -MMD -MT ym/uvisor-lib/source/CMakeFiles/uvisor-lib.dir/error.cpp.o -MF ym/uvisor-lib/source/CMakeFiles/uvisor-lib.dir/error.cpp.o.d -o ym/uvisor-lib/source/CMakeFiles/uvisor-lib.dir/error.cpp.o -c C:/Users/user/workspace/Blinky/yotta_modules/uvisor-lib/source/error.cpp
C:/Users/user/workspace/Blinky/yotta_modules/uvisor-lib/source/error.cpp:17:35: fatal error: uvisor-lib/uvisor-lib.h: No such file or directory
 #include "uvisor-lib/uvisor-lib.h"

(文亮 林) #11

Not easy to build...
Always error

ninja: build stopped: subcommand failed.
error: command ['ninja'] failed

(Martin Kojtal) #12

@momososo, please provide more details, I havent seen just failed yet :smile:

@SamKent Which example are you building? I suspect as you are using windows and those paths seem to be long, might happen that they exceed win path limit, where you might end up with "weird unexpected errors".

(Sam Kent) #13

Just trying to build the Blinky example, it will build using the tool installed by the automated installer but I would like to be able to automate the build process in an IDE using the command line tools.

I've moved the example project to C:/blink and still get an identical error!

(James Crosby) #14

@SamKent It looks like the include paths are completely missing from your command line. To debug this it would be helpful to see your ./build/<targetname>/ and ./build/<targetname>/ files. (If you aren't able to upload here, please open an issue at, where you should be able to attach files.)

Just to confirm a few other things:

  • Did you install using the automated installer? (
  • what cmake version do you have (cmake --version)?
  • what compiler version do you have (arm-none-eabi-gcc --version)?

(Sam Kent) #15

Thanks for the reply!

Didn't use the automated installer, installed manually following the guide. A colleague has an automated install which he can build a project with when going through the tool started by the 'Run Yotta' scripts, but can't build straight from cmd.exe. - -
(Github wouldn't allow me to upload it and threw an error when I uploaded as a .txt)

cmake version 3.4.0-rcl
arm-none-eabi-gcc 4.9.3 20150529 (release) [ARM/embedded-4_9-branch revision 224288]

(James Crosby) #16

OK – that's to be expected. The intention with the installer is that it doesn't pollute your system path, so to have the paths set up correctly you have to start through the run-yotta script (or source that script from an existing terminal).

From the .ninja files it looks like CMake is setting the includes correctly, but ninja hasn't propagated them to the compiler invocation command line – what ninja version are you using (ninja --version)?

(Sam Kent) #17

Ninja 1.5.3

So if I'm setting up a build in Eclipse should I also download the installer and run the .bat files as part of my build command?

(James Crosby) #18

Yeah, that'd be the easiest way to do it.

(James Crosby) #19

@SamKent It looks like your problem is caused by using CMake 3.4 – we're working on understanding why exactly this breaks things, but for the mean time could you try using an earlier CMake version?

(Sam Kent) #20

Builds! Great, thanks

Important Information for this Arm website

This site uses cookies to store information on your computer. By continuing to use our site, you consent to our cookies. If you are not happy with the use of these cookies, please review our Cookie Policy to learn how they can be disabled. By disabling cookies, some features of the site will not work.