Old Mbed Compiler


I haven’t worked with my old Mbed OS project for a while, last time in November last year when old Mbed compiler was available. Today I’ve tried to import my old code but into Keil Studio and I can’t compile any more. For my project I’m using specific versions of mbed and mbed-os libraries so my guess is that causes issues.

I’m trying to build with mbed os tools-release-5.15.0-1 but I’m getting following error:

Using toolchain ARMC6 profile {‘ENV’: {‘ARMLMD_LICENSE_FILE’: ‘8224@’}, ‘PATHS’: {‘ARMC6_PATH’: ‘/opt/ARMCompiler6.15.13/bin/’, ‘ARM_PATH’: ‘/opt/armcc5_06_u6/’}, ‘common’: [‘-c’, ‘–gnu’, ‘-O3’, ‘-Otime’, ‘–split_sections’, ‘–apcs=interwork’], ‘cxx’: [‘–cpp’, ‘–no_rtti’], ‘COMPILE_C_AS_CPP’: False, ‘NEW_SCAN_RESOURCES’: True}
scan /tmp/chroots/ch-33230833-f7ab-421e-a593-dc6e5ec37567/src
scan /tmp/chroots/ch-33230833-f7ab-421e-a593-dc6e5ec37567/extras/mbed-os.lib
Library name ‘RM1000_AT’ is not unique (defined in ‘/tmp/chroots/ch-33230833-f7ab-421e-a593-dc6e5ec37567/src/mbed-os/features/cellular/framework/targets/RiotMicro/AT/mbed_lib.json’ and ‘/tmp/chroots/ch-33230833-f7ab-421e-a593-dc6e5ec37567/extras/mbed-os.lib/connectivity/drivers/cellular/RiotMicro/AT/mbed_lib.json’)
Internal error.

Do you know if there is any other possibility how to compile my old code?


solution is, solve your issue.

You have a collision between two versions of Mbed OS libraries.

This is MbedOS 5 path
However this is MbedOS6 path

BR, Jan