Arm Mbed OS support forum

Online Compiler - failure code 504 - Gateway Time-out

Most of the time over the last week the Online Compiler has been offline, but when online and while appearing to work it refuses to save edits to any files. The browser ‘wheel of death’ spins for several minutes before giving way to the message : -
Server responded with a failure code 504 - Gateway Time-out

Click OK to retry.

Then you can waste the rest of the day retrying to no avail.
OK I understand the wish to sweep us all off the online compiler, but we need it to keep on working for at least as long as it’s going to take to put ourselves through all the needless pain of converting from OS2 to OS something else!

Any help gratefully appreciated.

Hi Jon,

We haven’t seen outages with the Online Compiler, which leads us to suspect there might be something about your particular set up causing this behaviour.

Can you save changes to other projects in your workspace? Also, are you using the standard Mbed 2 library?

Thanks,
Joe

Hi Joe,
Thanks for your response.
I have 10 or more active projects, all of which are/have been OS2 - the standard Mbed 2 library? - I assume so as I’ve never sought to change from it. I have made a start at trying to convert one of them to OS5.something, not made changes to any others, but for 99% of the time nothing works! Just tried accessing the compiler again -
https://os.mbed.com/ide/
and got nothing but a blank screen, except for “Loading …” mid screen which seems set to stay like that all day.

Problem my end? This is rural England where ‘superfast broadband’ seems no better than dialup much of the time, but can access any and all other web - google, youtube etc no problem.

My laptop? - Using Ubuntu / Firefox. No different with Opera.
Likewise, tried on three different Win 10 laptops with Firefox and Opera - exactly the same.

Been using the Online Compiler for nine years with very little problem, and telling The World how great it all is - quite prepared to live with the occasional short term outages down to Mbed, crap internet or whatever, but this is different.

Regards
Jon

Update. I deleted the project I was having difficulty migrating from OS2 to OS5. Coincidence or otherwise, normal service seems to be resumed.

1 Like

Thanks for the update Jon. Hopefully this has fixed the issue for you but please keep us updated if it recurs. Sorry for the difficulty with this.

If you’re porting from Mbed 2 have you checked the documentation on the Mbed OS 6 bare metal profile? This might prove to be a more reliable approach.

Thanks Will,
I’ve read the doc on Mbed OS6 bare metal profile, and this looks promising as most of my projects are ‘bare metal’ ish by design, but near the top of the first page the claim is made : “The Mbed OS build tools - Mbed CLI, Mbed Online Compiler and Mbed Studio - all support working with the bare metal profile.”. The text continues seemingly relating only to CLI.

I’ve not found a way of working with OS6 on the Online compiler, but have started trying to work with ‘Studio’. If I understand correctly, Online-Easy (thank you all so much!), Studio-Harder, CLI-Hardest. Maybe I’ll learn CLI one day but I certainly don’t have the time right now.

Next problem - I can’t live with simplex comms using stdio. ALL of my projects use full duplex serial comms through the USBTX and USBRX pins. There’s hardware out in the field, changing pins is not an option. Ideas on a fix - much appreciated.