Please let me know what to do after chip erase.

I am using STM32H747I-DISCO (MB1248-H747i-D02) board in ARM’s mbed development environment.
Using STM32 ST-LINK Utility, I did “Erace Chip”.
After that, as mbed, the program cannot be written to the board.

I wrote ST-LINK, but as mbed, I can’t write the program to the board.
Also, it is not possible to connect to the board from STM32CubeProgrammer.
(When connecting the board to the PC, it will be recognized as a drive)
Please tell me how to resolve.

the chip erase is normal operation and it is necessary nothing special so the issue will somewhere else.

The drive is ST-link memory for drag & drop program upload. Its capacity should be 2MB+, if the capacity is very low then your MCU is not properly powered - a jumper can be in wrong posion or a short circuit on the board.

For connecting via STM32CubeProgrammer try to choose mode “Under Reset”.

Of course update ST-link firmware is recommended.

BR, Jan

Thank you for your advice.
I set it to Under Reset mode using the STM32 ST-LINK Utility.
(STM32CubeProgrammer) cannot be used because there is a phenomenon that it cannot be connected to the board.
STLINK has written the latest version.
I did the above, but the phenomenon that the mbed program cannot be written continues.

Before conducting this experiment, I set the “Read Out Protection” function from the STM32CubeProgrammer.
Is this related?

I do not know, it should be reverted with Full chip erase I think.

The board has ST-link the STM32CubeProgrammer/ST-LINK Utility connects to the ST-link and provide the conection with the MCU. So STM32CubeProgrammer is not able connect to ST-link or ST-Link is not able connect the MCU?
BTW ST-LINK Utility was replaced with STM32CubeProgrammer, so it is hard to say what result is better.

Latest firmware STSW-LINK007 - ST-LINK, ST-LINK/V2, ST-LINK/V2-1, STLINK-V3 boards firmware upgrade - STMicroelectronics.

BR, Jan

Thank you for your advice.

Currently, there is a problem that the “STM32 ST-LINK Utility” and “STM32CubeProgrammer” on the PC cannot connect to the microcomputer board.

“ST-Link Upgrade” of “STM32 ST-LINK Utility” worked. However, even after that, I still cannot connect to the microcomputer board from “STM32 ST-LINK Utility” and “STM32CubeProgrammer” on the PC.

If you have any advice, please let me know.

Ok, once again the STM32 ST-LINK Utility is old and its updater is pointless.

  • Updater from link above V2.J42.M27
  • Updater from ST-Utility V2.J37.M26

Try to download the ST-link updater directly

BR, Jan

Thank you for your advice.

I downloaded the file you gave me from the link above.
And I updated ST-LINK.

When connecting from STM32CubeProgrammer to the microcomputer board, I can't connect with the error "Error: ST-LINK error (DEV_TARGET_NOT_HALTED)". Also, even as mbed, the file cannot be written.

I don’t know what to do.
I’m in trouble.

If you have any other advice, please let me know.

Can you please share a picture of your Stm32CubeProgrammer settings? Just for sure.

BR, Jan

thank you for your reply.
We will send you a hard copy of the Stm32CubeProgrammer setting screen.

Thank you very much.



Try to change

  • Mode: Under reset
  • Reset mode: Hardware reset

BR, Jan

Thank you for the address.
STM32CubeProgrammer can now connect by pressing the Reset button.

From STM32CubeProgrammer, I tried to write the chip erase and ST-Link again.
mbed programs cannot be written.
For mbed, do I need to install anything?

You every time write “the chip erase”. That means you performed the full chip memory erase? (Done via button with rubber, left panel, second from bottom)

Ok and what method do you use for mbed binary upload?

  • drag & drop - manual insertion of mbed’s binary file into ST-Link’s disc drive
  • Direct deploy from Mbed Studio or KeilStudioCloud
  • mbed’s binary file is uploaded via STM32CubeProgrammer
  • any else

BR, Jan

“Full chip erase” is just that.
It was implemented by pressing the second button from the bottom left of STM32CubeProgrammer.

In addition, we have tried the following two methods for programming mbed.
Manually inserting the mbed binary file into the disk drive
・Write directly from Mbed Studio

Thank you very much.