Unable to upload program to board

:frowning: am using a B-L475E-IOT01A board and after I uploaded an example (mbed-wifi-example) using Keil Studio and suddenly I can’t reupload it again, it says “mbed-wifi-example failed to run”. I’ve checked the documentation and tried solutions from there but still nothing. I’ve been working on the board for a while with the same cable and did not have this issue until now. I’ve tried another cable, still the same. Serial monitor is working though, and when I connect it to the PC, file explorer with the board content is opened. STM32CubeProgrammer says Error: No STM32 target found!
I can however put the binary generated by Keil Studio’s build in the directory, and it works (LD6 is yellow however and I don’t know if that’s good or not) I attach some screenshots below:

Screenshot 2023-02-22 085809

Please help :frowning:

Hello Hady_Badleh,

I have tried to reproduce the problem you had encountered using the following setup:

  • Keil Studio Cloud v1.5.55
  • ‘mbed-os-example-wifi-5’ project with mbed-os 5.15.7
  • ‘mbed-os-example-sockets’ project with mbed-os 6.13.0
  • DISCO-L475VG-IOT01A (B-L475E-IOT01A) board with firmware version V2J40M27

When performing the Run operation using either of the two projects it fails to run and pops up the notification you’ve included in your above snapshots and the output view reports the following…

Screenshot 2023-02-22 at 13.09.34

I then accessed the Preference settings from the File menu and changed Debug > Connect Mode from haltOnConnect to underReset

When performing the Run operation again using either of the projects it is now successful, i.e. failure notification no longer appears and the output view now reports the following…

Note that the documentation button from the failure notification takes you to the troubleshooting section, which provides various suggestions including changing the connect mode setting to underReset. This setting should work well for ST boards.

Also if your firmware is not up-to-date on your board try updating your firmware to the latest version. The firmware update procedure is detailed in the documentation.

Let me know how you get on.

Kanthan - Studio team