Arm Mbed OS support forum

Request build failed with message: EPERM: operation not permitted; BUILD.mbedignore'

My copy of Mbed studio has stopped working in the weirdest of ways and now I cannot get working again. On Wednesday I opened the app as usual and it flashed up to say there was a new version which I declined to install.

On Thursday I booted my laptop, went to run Studio, and the .exe had completely vanished! The program directories were still there, but no .exe. It wasn’t in my trash box and I hadn’t done anything with it.

So, I downloaded the latest version, ran the installer and this failed, unable to write the un-installer.exe. I tried to run the un-installer that was still present in the program folders and this refused to run.

Next, I deleted all the original program folders and ran the new installer again and this time it installed successfully. On running studio, I then got “Caching MBed OS to speed up your development workflow” which stuck at 19% and went no further.

Finally I tried uninstalling and reinstalling, and this time the Caching MBed worked and I was able to run studio. Hurrah I thought, back in business, but no! When I compile my program I get:

Project build failed: Request build failed with message: EPERM: operation not permitted, open ‘c:\Documents\MBED\Interface_Test_6\BUILD.mbedignore’

I’ve tried deleting “BUILD.mbedignore” but this doesn’t make any difference. Any ideas?

Hi @rogermcardell,

Thank you for reporting this issue. I think there are 2 problems here:

  1. Files were missing because auto-udpate hasn’t finished correctly. In case of declining the update, it is installing in the background after Studio is closed. It is possible that not all files have been installed correctly before you closed the system. The installation should resume after the system is restarted. We will look into it. In the meantime deleting Mbed Studio and reinstalling it should help in this case.
  2. EPERM: operation not permitted. We haven’t seen this problem yet. Is the program you are building public somewhere? Can you share a link to it? What version of Mbed OS does it use? I see that tools inside your version of Mbed OS are looking into wrong path. the .mbedignore file should be in {program_path}\BUILD\.mbedignore instead of {program_path}\BUILD.mbedignore.
    Would you mind checking if you can build other programs?

Thanks,
Arek - Mbed Studio team

Hi Arek,

This is probably a really stupid question, but how do I tell what version of Mbed OS it’s running?

I eventually solved the problem this morning and it’s working again now! It turns out my anti-virus program was blocking Studio. Annoyingly this is actually the first thing I thought of when I had the issue, but checking through I couldn’t see it on the blacklist. For reference, I’m running Bitdefender.

Regards

Roger