Arm Mbed and Pelion Device Management support forum

Installation Aborted on Win10

Hi, I’ve downloaded Mbed Studio Intaller for win 10: MbedStudio-0.9.1 but when I start install I get “Installation Aborted” and “Setup was not completed successfully”.
The same installer works on other PC with Win10.
Now I’m on Lenovo Yoga 520. I tried to run “only for me” and “for all users” or to change directory but nothing has change.

Is there a way to manually install it and its components?

Hi Fabio,

Thank you for reporting this issue. Unfortunately not at the moment. Installer is the only way to install Mbed Studio on Windows. Would you mind answering few questions? It will help us in investigating this issue on your system.

  • What is your exact Windows 10 version? You can check it by running: windows_key+R and starting winver.
  • Do you have any Antivirus program installed? Other than Windows Defender?
  • Is your Windows 10 a 32 or 64bit version?
  • Do you have at least 3 GB space on your disk left?
  • Have you installed Mbed Studio on that computer on different user before?

Thanks,
Arek - Mbed Studio team

Thank for your answer.

My OS is Windows 10 Home ver. 1903 build 18362.778 - 64 bit
CPU: Intel Pentium 4415U @ 2.30 GHz - 64 bit
RAM: 4GB
Free Disk Space: 42 GB on SSD
I have only WinDefender
I have only this user but when I try to install Mbed Studio it say “There is already a pre-user installation. (C:\Program Files\MbedStudio) Will reinstall/upgrade”
This note is shown also if I delete the folder (C:\Program Files\MbedStudio).

Maybe I need to “deep” uninstall it (on win reg for example) but how?

I have extracted .exe file and runned MbedStudio.exe. I can open the program but nothing work: compiler shows errors, USB not found, no library found, etc.

If I have a list of things that setup.exe do, I can do them instead manually.

Let me know If others info are needed or what I can do to install the programm.

Thank you for providing more information. We haven’t seen this issue before. We’ll check the exact version of Windows you are using. In the meantime would you mind trying to follow those steps? It should remove all Mbed Studio files from the system.

  1. Please run an uninstaller for Mbed Studio. You can use either Add/Remove Programs or find uninstaller in your Mbed Studio install location.
  2. Please check that following paths do not exist. Please delete those folders in case that they are still there: C:\Program Files\Mbed Studio, C:\ProgramData\Mbed Studio, ~\AppData\Local\Programs\Mbed Studio, ~\AppData\Local\Mbed Studio.
  3. Install Mbed Studio again

What comes to my mind is that it is possible that restart is pending on your Windows system. That’s why Studio can’t be installed correctly. Restarting your system may help in that case after uninstallation.

I can point you also at registry but it shouldn’t be required. Uninstaller should be able to remove all Mbed Studio information from registry.

Please let us know if those steps worked for you. In the meantime we will investigate this issue on the same build version of Windows 10.

PS: The reason while nothing worked for you when you extracted just an executable is the fact that tools shipped with Mbed Studio were missing on your system. Mbed Studio is shipped with many tools that are required for most functionalities present in the IDE. In case you are interested, you can see the list of tools shipped with Studio here: https://os.mbed.com/docs/mbed-studio/current/installing/system-requirements.html

Thanks,
Arek - Mbed Studio team

1 Like

Thank you for your help.
You’re right. There was a pending restart on Windows.
For a moment I forgot the first rule of coder: “shut-down and re-power-on” because I’m working on several project and to avoid closing and re-run IDEs and other research files, I put Windows in stand-by during last weeks.

Uninstall, restart and Install solved the problem.

Thanks a lot.

1 Like

Hi Fabio,

I’m glad that the problem is solved for you. Thank you for confirmation. I’ll add a ticket to improve it. Mbed Studio windows installer can detect pending restart and warn about it. We will try to improve it in the future.

Thanks,
Arek - Mbed Studio team

1 Like