Arm Mbed OS support forum

Suddenly getting: Error: Target not supported: Missing post-build hook

I have an mbed-os based project built with the online ide thats been running for about a year now with intermittent updates. All of a sudden (Within the last week) i keep getting this error when building:

Error: Target not supported: Missing post-build hook

for the EA LPC4088 QuickStart board.

Creating a new mbed-os program with a different board works fine. As soon as i switch to the LPC4088 the error returns. What could be the problem here?

Hi there,

be sure about your MbedOs version is 5.15 and not 6+
This board was probably removed for the future of MbedOS6+

BR, Jan

My version was indeed changed to 6, which is rather annoying, because i certainly did not specify that!
Even switching mbed OS 5.15.3 b6370b4c37 has not helped. I went to the revision tab and richt clicked -> switch working copy to this revision. Do i have to do anything else?

EDIT: I see that my board only supports Mbed 5.4 but i cannot see this version anywhere under revisions. How do i get that version?

MbedOS 5.4 is still on github, but I have no idea if it possible to import it to the online compiler, maybe it is possible to use it with the MbedCLi, you must try that.

Ive successfully switched to 5.4 by deleting my current mbed-os library and importing a new library from url https://github.com/ARMmbed/mbed-os/commit/fc1836545dcc2fc86f03b01292b62bf2089f67c3

this didnt compile for me, so i checked the last os version i successfully compiled against and it was 5.15.0! I then readded that version to the online compiler and compiled again. Now compiling works again but i am also getting the same error as at the start: Error:Target not supported.

How can it be that a target no longer is supported when ive successfully compiled for that target and against that mbed-os version just a few days ago?

Same issues here since this afternoon.

anyone solved this problem?

UPDATE: Ive create a blinky project, linking against mbed-os 5.4. This compiles successfuly but again gives me the same Error:Target not supported error. Has something about targeting an LPC4088 Quickstart board been broken?

Indeed did the same test, same result…

Thanks for raising this issue. We have confirmed it and are investigating.

I’ve seen the same issue with MultiTech MDot platform with mbed-os 5 projects.

It seems like the compiler is using the tools from mbed-os 6 and target definitions from mbed-os 5. Offline compiling with mbed cli works when the tools and targets are from the same mbed os version.

Post-build hooks were removed from the MDot in mbed-os 6.

Thanks for quick reaction time. I dont know if all issues are resolved, but my program compiles and runs as before.

Thanks for your patience and apologies for the issues you’ve seen.
We rolled back the changes yesterday to revert the update and get you working again.

A fix for the release has been implemented and should be deployed sometime next week.