Thread Border router S2LP

Hi all,
I’m trying run nanostack-border-router with X-NUCLEO-S2868A1 (S2LP) with minimal configuration changes. But still getting
[ERR ][s2lp]: Failed to change state from 0 to: 30
[ERR ][s2lp]: Failed to change state from 0 to: 5c
Antenna is original from x-nucleo. Any hits how to debug what’s going on?
Config is:
{
“config”: {
“radio-type”:{
“help”: “options are ATMEL, MCR20”,
“value”: “S2LP”
},
“backhaul-driver”: {
“help”: “options are ETH, SLIP, EMAC, CELL”,
“value”: “EMAC”
},
“mesh-mode”: {
“help”: “Mesh networking mode. Options are LOWPAN_ND and THREAD”,
“value”: “THREAD”
},
“backhaul-mac-src”: {
“help”: “Where to get EUI48 address. Options are BOARD, CONFIG”,
“value”: “BOARD”
},
“backhaul-mld”: {
“help”: “Enable proxying Multicast Listener Discovery messages to backhaul network”,
“value”: “false”
},
“nanostack_extended_heap”: {
“help”: “Add additional memory region to nanostack heap. Valid only for selected platforms. Region size may vary depending of the toolchain.”,
“value”: false
},
“backhaul-mac”: “{0x02, 0x00, 0x00, 0x00, 0x00, 0x01}”,
“rf-channel”: 22,
“rf-channel-page”: 0,
“rf-channel-mask”: “0x07fff800”,
“debug-trace”: 1,
“backhaul-dynamic-bootstrap”: true,
“backhaul-prefix”: ““fd00:300::””,
“backhaul-next-hop”: ““fe80::1"”,
“backhaul-default-route”: “”::/0"”,
“commissioning-dataset-timestamp”: “0x00010000”,
“pan-id”: “0x0700”,
“extended-pan-id”: “{0xf1, 0xb5, 0xa1, 0xb2,0xc4, 0xd5, 0xa1, 0xbd }”,
“mesh-local-prefix”: “{0xfd, 0x0, 0x0d, 0xb8, 0x0,0x0, 0x0, 0x0}”,
“network-name”: ““Thread Network””,
“pskd”: ““ABCDEFGH””,
“pskc”: “{0xc8, 0xa6, 0x2e, 0xae, 0xf3, 0x68, 0xf3, 0x46, 0xa9, 0x9e, 0x57, 0x85, 0x98, 0x9d, 0x1c, 0xd0}”,
“thread-master-key”: “{0x10, 0x11, 0x22, 0x33, 0x44, 0x55, 0x66, 0x77, 0x88, 0x99, 0xaa, 0xbb, 0xcc, 0xdd, 0xee, 0xff}”,
“thread-use-static-link-config”: false,
“thread-security-policy”: 255,
“LED”: “NC”,
“SERIAL_TX”: “NC”,
“SERIAL_RX”: “NC”,
“SERIAL_CTS”: “NC”,
“SERIAL_RTS”: “NC”
},
“macros”: [“MBEDTLS_USER_CONFIG_FILE=“source/mbedtls_thread_config.h””],
“target_overrides”: {
“*”: {
“target.network-default-interface-type”: “ETHERNET”,
“nsapi.default-stack”: “NANOSTACK”,
“mbed-trace.enable”: 1,
“nanostack.configuration”: “thread_border_router”,
“platform.stdio-convert-newlines”: true,
“platform.stdio-baud-rate”: 115200,
“mbed-mesh-api.heap-size”: 65535,
“mbed-mesh-api.heap-stat-info”: “&memory_heap_stat”,
“mbed-mesh-api.heap-stat-info-definition”: “mem_stat_t memory_heap_stat;”
} }
}

Thank you
Stepan

Did you have any luck with this issue? I have the same issue.

Jiwon

Hello, by the time, the issue may be resolved, but I’ll suggest something anyway : 0 is ready state and 30 is Tx state, and this specific switch between these state means generally there is an issue with the SPI. Make sure you don’t have to change some 0ohms resistors to remap the shield according to your board.

Hello, just to be shure you have this message, see my previous post :