Arm Mbed and Pelion Device Management support forum

Thunderboard Sense 2 will not download .bin image

Hello,

I downloaded and compiled on-line, TBSense2_Sensor_Demo

When I attempt to drag and drop the .bin file, it does not work. Inside FAIL.TXT file, I get the message “Error while connecting to CPU”

The TB2 shows up in the Window’s 10 file hierarchy as TB004 (F:)

I believe I upgraded the TB file system per the instructions given on the TB2 board page. Simplicity Studio says the “Adapter Firmware Version: 1v4p2b352”

…kevin

I haven’t heard anything and I am stuck here. Can anyone help?

Hi Kevin, I have this board so can help. I’m sure its got the same firmware as yours and does work, let me dig it out, connect it up and I’ll come back here shortly.

Okay, I’ve connected mine to a Windows 10 PC and have this in my MBED.HTM file:

<!-- mbed website redirect -->
<!-- Version: 1.4.2. build 352 -->
<html>
<head>
<meta http-equiv="refresh" content="0; url=http://mbed.org/device/? 
code=204101600001FC58D738CFC3"/>
<title>mbed Website Shortcut</title>
</head>
<body></body>
</html>

Compiled the demo (that’s using mbed os2 classic official library) and saved directly to the TB2 and is working.
I’ll try reloading the firmware on Simplicity Studio again and see what happens.

I can see I can roll back to previous versions in Simplicity Studio, can I suggest to roll back to the previous version, try it again on mbed and then reload the up to date version.

Tried that but couldn’t roll back the firmware, I think it only goes one way. However I loaded the TB sense 2 demo on Simplicity Studio that the board is shipped and that loaded and worked okay, so I suggest to try that and come back here…

Hi Paul,

My MBED.HTM file is the same except for the “code”

code=204101600001CF8CD738FC17

I too am able to compile and run the TB2 sense app, but only to this point:

sv = svl = i = r =

Supply voltage :
Supply IR :
Supply type : USB
Pressure sensor: BMP280 detected
HALL init status: 0
CCS811 init status: 0

Thunderboard Sense BLE application - 0.5.0 build 0

BLE address : 00:0B:57:BE:52:12
Firmware revision : 0.5.0
Board revision : A00
Board serial : 1234
Device name : Thunder Sense #21010 [20]

Adv: M O D E
Reset

Kevin, I think I have the answer.

I had the same terminal output as yours with some minor board specific differences.
I then tried to load SiLabs mbd blinky on mbed as usual, this one;

https://os.mbed.com/teams/SiliconLabs/code/mbed_blinky_low_power/

and… then I had the same issue as you have.
I think the SiLabs demo somehow blocks the USB MSD flashing.
To work around that simply, online compile the SiLabs blinky, drop it directly to the TB2 board WHILST pressing the reset button and release the reset button within a fraction of a second after you click save.
It should then load and start to blink the led as expected.
You may have to try a couple of times as the “click save and reset button release” timing can be a quite critical.

After that my TB2 works as normal.

Hopefully that should sort your problem, further to this I have had to do this on several other platforms in the past, something to watch out for.

Paul

I downloaded mbed_blinky_low_power and it doesn’t even compile.

Let me take that back, after I updated mbed.lib from 125 to 172, it then compiled correctly. I still have the same downloading problem however.

Got it!!!

I down-rev’d the adapter firmware package from 1v4 to 1v3 and now it downloads and runs from the mbed on-line compiler.

S1015C_adapter_firmware_package_0v2p3b115.emz
S1015C_adapter_firmware_package_0v4p0b193.emz
S1015C_adapter_firmware_package_1v3p0b266.emz
S1015C_adapter_firmware_package_1v4p2b352.emz

Is it helpful? Have the problem been solved?