Arm Mbed OS support forum

Uploading an existing workspace to Mbed

Hi! I’m a begineer to the Mbed environment. I have given the task of doing a minor software update to a software that has been already written by someone else. I have no way of contacting the original author. This software was written for a STM32F107, but I don’t know the development platform they use it. When I try to upload the workspace to the Mbed compiler it’s asking for a target platform. Is there a way to find the target platform? And how do you import the workspace after selecting the platform? Also is there a way to check the Mbed OS version they have used?

Hello,

The workspace is only a folder where are stored your projects and that can be easily selected but I think that is not your case.
You probably mean a specific Project, maybe you can share a link with us. However, I don’t think, it is possible without some extra work and especielly if your target is different one.

The target platform comes from MbedOS library, so you need to import MbedOS, somewhere '#include "mbed.h" (probably in a main file) and let Studio inicialize it.
When you create a new blinky example from template, what is a part of MbedStudio, then you have a template of a basic structure of MbedStudio project. Then you need to try transfer necessary files from the project what you want to convert to your new projec in MbedStudio.

Arm Mbed Studio - Arm Mbed Studio | Mbed Studio Documentation

The MbedOS version can be found via window libraries in MbedStudio or directly in MbedOS source (the path can be different in older versions of MbedOS but it will be similar)

BR, Jan

Hi @JohnnyK

Yes you’re right. I meant the project. I don’t know the target platform the software was written for. I’m updating the software for a PCB board which has a STM32F107 MCU.

Thanks for your help

I forgot to mention…
Before you will start the things what you mention above, be sure your target (STM32F107) is supported under Mbed and it is working.

BR, Jan

I just found out that STM32F107 target is available on Mbed Studio but not on the online platform and the Mbed version used is 5.14.2. But now the next problem is I’m getting this error messages when try to build

Do you have any idea how to fix these errors?

I don’t know where, I do not see that in the MbedStudio - target section. Also in the source MbedOS 6 master and MbedOS 5.14, the F107 not exist.
Maybe it can inherit from F103 but I don’t know how different they are.

About the errors, it seems like your instalation is broken, just try to reinstall it maybe. All parts what are used by Mbed Studio are parts of installation.

BR, Jan

If you look for STM32_F107 you should be able to find it. But this not there in the online version

image

I tried uninstalling and reinstalling, unfortunately that didn’t fix these issues.

I’m also getting this error

image

I just found out that this software was writting using an open source IDE not Mbed Studio. Hence why I’m keep getting these errors. It’s all good now. Thanks for your help

My suggestion about reinstalling was in the context of errors from Python and clangd.

The STM32_F107 must come from the project what you tried, it probably contains custom_target.json file where is this settings. Because how I wrote, MbedOs not contain the F107.

BR, Jan