Arm Mbed and Pelion Device Management support forum

Version 0.91 suddenly unlicensed

Edit: problem solved, should’ve followed the link in the error message before coming here…

The licence doesn’t allow operating MBed Studio via Remote Desktop SIGH

Been using MBed Studio since around V0.5(?) with no issues. 

Upgraded to 0.91 as soon as it was released (a couple of weeks ago?) and it worked with no problems.

Came back to it today after some hiatus to work on an existing project (same one as above when working) and I get the following when trying to build:

Building project mbed-os-test (LPC4088, ARMC6)

Scan: mbed-os-test

Compile [100.0%]: main.cpp

[ERROR] armclang: error: Failed to check out a license.

armclang: note:

Information about this error is available at: http://ds.arm.com/support/lic56/m103

General licensing information is available at: http://ds.arm.com/support/licensing/

If you need further help, provide this complete error report to your supplier or license.support@arm.com.

- ARMLMD_LICENSE_FILE: 'F:\Program Files\Mbed Studio\tools-config\ac6-license.dat'

- LM_LICENSE_FILE: unset

- ARM_PRODUCT_DEF: unset

- ARM_PRODUCT_PATH: unset

- ARM_TOOL_VARIANT: unset

- Product location: c:\Users\Chris\AppData\Local\Mbed Studio\mbed-studio-tools\ac6\sw\mappings

- Toolchain location: c:\Users\Chris\AppData\Local\Mbed Studio\mbed-studio-tools\ac6\bin

- Selected tool variant: product

armclang: note:

- Checkout feature: mbed_armcompiler

- Feature version: 5.0201910

- Flex error code: -103

Product: ARM Compiler 6.13 for Mbed Studio

Component: ARM Compiler 6.13

Tool: armclang [5d895a00]

Did a complete uninstall and re-install with the same result - is there some kind of licence refresh required?

Hi Chris,

Yes. Unfortunately, it is a current limitation of Arm Compiler. It doesn’t work in remote desktop: compiler error
We are working with compiler team to find out what we can do about it. In the meantime we will document this issue in known issues section in docs: known issues

Thanks,
Arek - Mbed Studio team