ARMmbed

Build fail with cmake on Blinky app

Hi,

As I’m new on mbed I’m trying to compile with yotta instead of the online tool.
Well I followed all the yotta instructions for linux users (I’m on manjaro).
Clone the example-mbedos-blinky git enter into it, perform a yotta target frdm-k64f-gcc and next a yotta build. Here is next the output I have:
http://pastebin.com/sUL4vPGd

If you need here is the CMakeError.log: http://pastebin.com/MCWH2RT6
And here is the CMakeOutput.log: http://pastebin.com/mNnRVxXf

I really don’t know what appends. Moreover, 2 days ago I was able to build on the same computer before I reinstall my manjaro yesterday… Maybe I missed a library but can’t find which one…

Thanks,

RoToR

Just tested on a clean target and that went fine… Can you run:

yt update
yt clean
yt build

If that fails can you post the content of your module.json file?

Looks like this error is caused by the combination of CMake 3.5 and your build target: what’s the output of yotta target? (A yotta update should update these, which will probably fix the problem)

Hi janjongboom,

Here is the output : http://pastebin.com/vCWQyKgg

There is still a problem…

jamcro01: Here is the output of yotta target:
http://pastebin.com/ELJjZq3e

Thanks. Should be fixed by mbed-gcc 1.2.1 (run yotta update, then yotta clean once more!)

1 Like

You guys are AWESOME !!!

Everything works well !! Here is the output for futur person who may pass here: http://pastebin.com/m2zBvSfM

Thanks a lot !

Okay well…
Tried to remove the git and try again with a clean git and now have compile error when I try to build for another official board (for example F401RE) which did works well in the past.
output: http://pastebin.com/yrqDba7f
Same problem after a yotta update and a yotta clean
Sorry I don’t really know how everythings works but it looks like it on the mbed library that the error is.

Maybe when you updated the mbed-gcc it created compilation errors on some devices; for example when I run a yotta target:
st-nucleo-f401re-gcc 0.2.5
mbed-gcc 1.2.1

How about adding the following dependency to your module.json?

"mbed-hal-st-stm32f4": "1.3.3"

Downgrading the mbed-hal-st-stm32f4 version resolved the same error in my project.
I filed a ticket regarding the issue.
Hope it works.

Hey it works !

Well, how did you find that solution ?

Now I’m trying to build for my F411RE (no official support…) and… ninja fail ! Awesome :joy: (but already had this error so that’s “normal”)

Thanks for the help everyone and @jamcro01 I’ml interested about your point of view for theory I had on my previous post !

I don’t think the mbed-gcc 1.2.1 target fix would have caused the second build failure, but other things might have been updated by yotta update. I think @dbaba’s analysis is correct.

Good to know.

Well, I did nothing special. I got the error when I renamed yotta_modules and yotta_targets in one of my projects for testing the latest dependencies. Until then, yt build had worked fine. So I thought either modules or targets caused the issue.

However, I focused on dependency modules rather than targets since some of my other yotta projects had already included the latest targets and of course, could be built without errors.

In order to identify problematic modules, I wrote down all dependencies (library names and their version) into module.json.
Then I removed a dependency one by one (removed more at once if possible) until the compilation failed.