Arm Mbed OS support forum

Building any project fails, debug.json file missing

Not sure where I am going wrong with this problem. I have tried on a Windows and Mac machine each with a newly installed Mbed Studio v1.4.1.

Trying to run any project to a Nucleo L031K6 board fails. The error says it’s looking for a debug.json file in a folder ‘tools’ in the project. No such folder is created on either machine. This is the mbed-os-example-blinky-baremetal project. Nothing I have searched for online even comes remotely close to helping.

Any ideas where I am going wrong here?

Hello,

I don’t know which version of Mbed OS you were trying but this target is not supported in MbedOS6+
and the last where that target was supported seems to be MbedOS 5.15 and only under bare metal profile.

But all oficial sources say only about Mbed 2 and MbedStudio support only MbedOS 5.12+ I think.

BR, Jan

1 Like

Hi Johnny,

Thanks for the reply, not sure how I didn’t notice this board was that old. I ended up ordering a different board to play around with. I got an Nucleo-F303K8 board now and flashed the latest st-link firmware. Mbed Studio recognizes the target device but building the project shows the same error

‘file:///c%3A/Users/lamothk/Mbed%20Programs/mbed-os-example-blinky-baremetal/mbed-os/tools/profiles/debug.json’ has not been found.**

I recreated the project and it doesn’t even make a ‘/tools/profiles/’ directory.

Hello Kevin,

ok, that is little bit better I also have this small Nucleo :slight_smile:
I tried mbed-os-example-blinky-baremetal with Nucleo-F303k8 with MbedStudio 1.4.1 (Win 10) and MbedOS 6.8 and also 6.11. Build and Deploy seems be ok.

It seeems like it is corrupted because these files are part of MbedOS - mbed-os/tools/profiles at master · ARMmbed/mbed-os (github.com)

BR, Jan