Arm Mbed OS support forum

Cannot use Mbed OS 5 on Linux

Hello,

We are working on a project using Mbed. The project was created in Mbed OS 5 and it was transfered to a Linux system. Following installation steps for Linux, Mbed OS 6 was automatically installed and I can’t find a way to get or switch to Mbed OS 5.

The problem is that some APIs such as Serial and raw Serial are used everywhere in the project, to the point that it has become really hard to make it work in Mbed OS 6.

I spent two days googling and trying how to install Mbed OS 5 on linux but nothing worked.

I would appreciate some clear steps explaining how to get Mbed OS 5 on linux, or a way to run the program.

Thank you in advance,

Pierre-Yves

I assume you have installed Mbed CLI. You can use the update command to choose OS 5. In the mbed-os directory, update the OS to whatever version you want.

mbed update mbed-os-5.15.5

This page may be helpful.

Hello,

I had tried through Mbed Studio and Mbed CLI and the command you mentioned didn’t work (i don’t remember the error but i tried it).

The project was transferred again to the Linux system and this time it worked. Either the first transfered archive was corrupted in some way (didn’t seem like it) or, one of the multiple commands i tried on the previous workspace finally took action in the new workspace from the new imported project (which is exactly the same).

Not sure what solved the problem but it was solved, thank you for your reply nonetheless. I guess I will mark this post as “Solution” even if I doubt it might be useful.