Arm Mbed OS support forum

Can't upload to Nucleo-H743ZI2 board

I can’t upload to Nucleo-H743ZI2 board. Mbed studio says the file was deployed but nothing happens. I tried to reset manually but also with no luck. The board has ST-Link v3.
My Nucleo-F767 board works well. I attached some screenshot, the link symbol is green for Nucleo-F767 but orange for Nulceo-H743.
Nucleo-H743ZI2
Nucleo-F767ZI

1 Like

Does it work if you do it manually?

No, how to do this?

You drag and drop the bin file to the board.

The goal is to know if the problem is with the upload of with the code not working on the H743.

It is an upload problem, because I see an old blinky example running.

The point was about the project what you tried with the MbedStudio.

Open the build folder of your project and manually Drag & Drop the binary.
...MBEDSTUDIO_WORKSPACE\YOUR_PROJECT_NAME\BUILD\YOUR_TARGET_NAME\COMPILER\Your_Project_name.bin

BR, Jan

I know about this method. But the question is why does it not work by st-link instead of drag and drop. Is this a stlink v3 problem?

Maybe someone from Mbed Studio team @arekzaluski @federicobozzini can clarify that.

BR, Jan

Nucleo-H743ZI2 works well on my environment windows10 64bit.


Please check ST-Link firmware version.
Latest as of today is V3.J5.M2.

All version are the latest versions including st-link. I’m working on macOS 11.2.

Intel or M1?

MacBook Pro Intel, but I can also try with my new macMini M1

You can, but I think you’ll run into more issues with the M1 :frowning:

I have this problem too!
I can’t upload to nucleo-h743zi2 from Mbed Studio on my work PC (Intel, Win10 x64). Also debug is not working. Only Drag&Drop works. But upload and debug works if I use PlatdormIO instead Mbed Studio.
On my home PC (AMD Ryzen, Win10 x64) I can upload code from Mbed Studio only when I set Deploy and debug target as None (Use mass storage copy for deploy). Debug not works.
I didn’t found any solution for it. Is it PyOCD problem?

Are you shure?
image

Meanwhile I can upload with Mbed Studio, but Mbed Studio use drag & drop instead St-Link,
this definitely a bug. Nobody answered about the question why is the link symbol orange instead green.
One problem was caused by a buggy version of Mbed or PIO however, I used ST-Link utilities to repair the board (option ‘connect under reset’ and erasing the chip).

Upload with St-Link works on PlatformIO. It looks like that upload doesn’t work with St-Link v3

Back to original question.

(1) My interpretation for “upload” is
→ Push [Run Program] → Create bin file → write bin file via STLink into H743ZI2 chip → run program
H743ZI2

I can do it on my PC and my program runs on Nucleo-H743ZI2 board.

(2) The link symbol color
My screen color is orange as you can see above screen shot.
This is NOT related “upload” issue but related “Debug” operation.
I can NOT do the debugging with using breakpoint, trace and others.
This is current situation and (I hope) arm team will extend debug enable boards includes H743ZI2.
You can check at here.
debug_suport
As of today, we can use only 18 boards!

For ST-Link Upgrade, V3.J7.M2 is latest.
Thanks SD.
I’m using STM32 ST-LINK Utility v.4.1.0 but latest v4.6.0 (as of Feb.10th, 2021).