Enabling Mbed Studio Debug Session

I am using the MAX32630FTHR and trying to get a debug session started within Mbed Studio. I can build the project but I am not able to run or debug the program to the device. The “play” and “debug” icons are not enabled.

Could someone please push me in the right direction? :slight_smile:

Thank you.

You are connecting to the board using just micro USB cable, correct?

When you connect the board, does it show up in the target in mbed studio?

I am using a dedicated programmer, but when I connect it the Mbed Studio prompts me for configuration of the device.

Welcome in the MAX32630FTHR club… :slight_smile:
A board that has great HW specs, but since about OS V5.9 it Maxim team hardly updated anything while mbed itself evolved a lot… so be prepared for similar flaws with this target.

When i bought my MAX32630FTHRs they were delivered with MAXREFDES100HDK programmer boards, but Mbed dropped support for this one some weeks ago. Before that time i could upload my code to the board by clicking the “play” button in Mbed Studio. Debugging was not available even back then.
Since MAXREFDES100HDK is not supported i always have to drag my .bin file onto the DAPLINK drive in the filemanager.

However i got some info that the MAX32625PICO can be used as a programmer board for the MAX32630FTHR and Mbed supports it. If that is true just grab the MAX32630FTHR compatible FW from this link

Just tried it myself and with the MAX32625PICO i can indeed program and also debug the MAX32630FTHR.

Hello Ante,

I am using the MAX32625PICO board that is coming up as COM4 *DAPLINK" on my computer.

When I plug in the MAX32630FTHR board to my PC I see this come up as COM 3 on my computer.

With the programming cable I am then connecting the MAX32625PICO to the MAX32630FTHR board (DAPLink connector).

Below I am showing the screen in Mbed studio where I can build the project and the target is coming up correctly (MAX32630FTHR) but I don’t have the play or debug option.

Thanks for any comments.

Hello Peter,

From the link you sent what file are you using?

There are a couple of options for the MAX32630FTHR target.

I tried with the max32625pico_daplink.bin image and Mbed studio then popped up a window that a probe was detected and asked if I wanted to configure the probe. But when I open the example project up I don’t see the play or debug icon being enabled.

I am trying to load the mbed-os-example-blinky to just try to program and blink an LED.

thanks for any comments.

I downloaded max32625pico_max32630fthr_if_crc.bin firmware (interface version 0254) and then burned that on to the PICO board in MAINTENANCE mode.

To get to that mode you have to hold down the button on the PICO board while you plug it into your computer, burn the FW, unplug from the computer, connect PICO to the FTHR, connect both to the computer.
It should be fine that way, otherwise you might have a broken PICO.