Mbed forum

Export to IAR systems


(Bob Hohlfeld) #1

I am trying to export a working mbed project to IAR systems using the export utility. I reported the problem to support@mbed.com 5 days ago and haven’t gotten any response. I’m uncertain as to the next step.


(Ralph Fulchiero) #2

Hi Bob,

We’re terribly sorry but we have not seen the email you sent to support@mbed.com so a case wasn’t generated to investigate the problem.

Could you describe the problem you are having? What board are you using?

Are you performing the export from the Online Compiler? If so, could you clone the project to your desktop and then export it using the Mbed Command Line Interface (CLI) with “mbed export -i iar -m mcu”? If you don’t use the CLI, you can obtain it here:

Regards,
Ralph, Team Mbed


(Bob Hohlfeld) #3

Hi Ralph,

Thanks for getting back to me.

I am using the Nucleo-F401RE. After updating all libraries, etc., I tried to export to the “iar” selection (working in the online compiler environment). About halfway through the export, it errored out with a message to e-mail support@mbed.com.

I will try your suggestion of using the CLI and get back to you later this evening.

Best regards.

Bob


(Ralph Fulchiero) #4

Hi Bob,

We’ve just tried exporting a Mbed OS2 and a few OS5 projects to IAR with the Nucleo-F401RE platform selected. We didn’t experience any problems but these were relatively small projects. Approximately how large is your project in terms of source/header files?

Do let us know if you had any issues using the CLI export.

Thank You,
Ralph, Team Mbed


(Bob Hohlfeld) #5

Hi Ralph,

There are two source files, one 5 kB in size and one 103 kB in size. The SDFileSystem directory is 308 kB and the mbed directory is 5.88 MB. When we build the binary in the online compiler the build shows 101.0 kB of Flash and 46.7 kB of RAM.

I was pushing forward with the CLI export and got about half-way through building the context and then got pulled off to evaluate some of our data gathered in our clinical trial. I’ll get back to the CLI export this afternoon and let you know how it went.

Best regards.

Bob


(Bob Hohlfeld) #6

Hi Ralph,

I believe I got all the software installed, and I’m following the instructions for the CLI Quickstart. I followed instructions removing bad links to libraries and using “mbed deploy” to bring in the libraries from the internet. I am now getting a message that the mbed compiler can’t find the mbed tools. The relevant part of the session is below:

PS C:\Users\rgh\Desktop\proto_copy\SDFileSystem> mbed compile
[mbed] WARNING: If you’re using Python 3 with Mbed OS 5.8 and earlier versions, Python errors will occur when compiling,
testing and exporting


(Bob Hohlfeld) #7

Ralph, has there been any progress in this area? Haven’t heard from you in a couple of days.
Bob


(Ralph Fulchiero) #8

Hi Bob - we aren’t actually seeing the error, but a warning related to building with Python 3. If you are getting an error on not finding the tools, please check the output of this command:

mbed config --list

You will have to set the path for your toolchain (Arm Compiler, GCC or IAR) as described here:

For instance, here is the output for my system where I have 3 compilers installed (Arm Compiler 5, Arm Compiler 6 and GCC):

$ mbed config --list
[mbed] Global config:
GCC_ARM_PATH=C:\Program Files (x86)\GNU Tools ARM Embedded\6 2017-q2-update\bin
ARM_PATH=c:\keil_v5\ARM\armcc
ARMC6_PATH=C:\Program Files\DS-5 v5.28.1\sw\ARMCompiler6.9\bin

[mbed] Local config (C:\_nrf\sandbox):
TOOLCHAIN=arm
TARGET=nrf52840_dk

Hopefully this will get you going!

If not, our CLI documentation can be found below along with a quick start tutorial:

Sorry that we didn’t send these to you previously.


(Bob Hohlfeld) #9

Hi Ralph,

Sorry, but I got pulled away from this (again) and can now pay some attention to the problem again.

I followed up on some of your earlier observations. I tried to export a smaller and simpler project (which also did not use the SD chip, which has been problematic for other reasons) and the export function ran without error. I tried putting the exported file in IAR workbench and it failed. After working with the IAR consultants, it develops that there is an object file retarget.o that is incompatible with their C++14 compiler. I have been unable to find source code for retarget in mbed. (They suggested recompiling that source in IAR.) They are also asking if I can get hold of source for the mbed library, for similar reasons.

Maybe you can illuminate the situation from the mbed side. Thanks.

Bob Hohlfeld