On-line IDE export program failed

After import mbed-os-example-mesh-minal sample, then I tried to export this sample as one Keil project. However, it prompt “An error occurred during export …”.
If I tried to remove mbed_app.json, it could export successfully.
It seems On-line IDE export feature is failure in parsing mbed_app json file.
Where or how to notify On-line IDE tool owner ?

I’m also unable to export projects. Unlike cyliang, removing/renaming the mbed_app.json doesn’t have any impact. Any suggestions would be appreciated.

My platform is the Nordic nRF52-DK. My project is a simple demo of the BLE heart rate service: https://developer.mbed.org/users/bsiever/code/nRF5-DK-HeartRateDemo/

Bill

Bill,

I had a look at your program. Are you familiar with our command line tool, mbed-cli? I was able to use ‘mbed import’ to import the project locally, then I used ‘mbed export’ to create a uvision5 project file. I know it’s not the optimal solution, but you can try that.

Here are some videos about mbed-cli and exporters:


And here is the mbed-cli documentation:

cyliang, this solution might also work for you, but I was able to test it on Bill’s provided example.

Sorry for your troubles.
Sarah

1 Like

Hi Sarah,
I know mbed-cli with right project-generator-definition for export program.
In my porting task, mbed-cli is a very good developing environment.
However, in my training course for FAE, On-line-IDE with export program feature is the better way.
Is there any plan or schedule to resolve these issues ?

project-generator-definitions is now deprecated, and everything you need to export is in the mbed-os tools. We are always working to improve the online IDE and export functionality, but, unfortunately these issues do arise. You can still use the online IDE, but mbed-cli will give you better error messages.

Does your project compile with mbed-app.json? I can try to recreate your issue. Is it possible for you to link me to the project?

Hi Sarah — Thanks for the suggestion and the rapid response. Will this only work with projects that have been published?

Yes, do you see the large yellow button that says “import into compiler”? That is also a drop down menu. Use it to change to “import with mbed-cli.”

You will need to have mbed-cli installed, so please follow the links above for information about downloading mbed-cli and using it to import and export!

I can see the “Import into Compiler” for my published projects via my public profile, but I haven’t noticed it anywhere else. Where/how can I import my unpublished projects? (By the way, I was able to import and compile my public projects via the cli. Thanks again for the rapid response)

Oh, great! If you were able import and compile with mbed-cli, navigate to the project on the command line and type mbed export -m NRF52_DK -i uvision5.

I believe the project must be published to use mbed import, so that it is a repository available for cloning with version control. You can publish it privately, such that no one else can see your project.

Thanks — I’ve already compiled it (with gcc) and am testing out debugging (via pyOCD). Your help was greatly appreciated!

Yes, it needs mbed-app.json. This project mbed-os-example-mesh-minimal is created by ARM mbed team. You could import mbed-os-example-mesh-minimal, then export as Keil project. You will got "An error occurred … ".