Fork or republish to Github

On one project, I have been unable to push to github (other projects work without problem).

It started with the inability to push a series of local commits. Since there was not much history on the project (i had probably only pushed once or twice) I tried to just create a new fork. At that point I received an error message stating:
“There was an issue connecting to Keil Studio Cloud. Please wait while we try to reconnect.”

The error log indicate that the system had disconnected from Github and then it would reconnect. After that error went away, I continued and it returned an error that there was already a fork and I needed to remove it using the Github user interface.

Again I was unable to find any existing forks of the project so I deleted the entire Github repository in the hope that I could simply re-publish to a new repository but it appears to have saved some information and will still not allow me to publish (the option is not enabled).

I realize, in hindsight, that I probably dug myself a big hole by deleting things but Is there some way I can start clean and save my commit history by publishing to Github?

Hello Chris Bailey,

Sorry that no one from the Studio team (including myself) has responded to you.

As you describe the Git Fork operation causes a temporary disconnection to GitHub, which prevents the operation from completing successfully.

We are currently working on a fix which should be available in one of the upcoming Keil Studio Cloud releases.

Kanthan - Studio team

Fyi, this has been fixed in KSC v1.6.11

Thanks. I’ll give it a try