Keil Studio Cloud not loading example project or any project

Running KSC on Chrome. I can connect my NUCLEO-F411RE. I can import my project from Mbed online compiler. But I get a spinning distractor next to the project name, and I can’t load any source code into the editor. Won’t build. Won’t do anything. I’ve updated the firmware on my target board. running MBED 5.

I try to load a demo project and it just doesn’t do anything.

Been very stuck, please help.

Hi @Phil_Reeves,

Thank you for reporting this issue. Would you mind answering few questions? It will help us in investigation.

  1. Have you tried to refresh Keil Studio?
  2. Does the problem exist only with this particular project copied from online compiler or does it happen for every project? Have you tried to create a new example using File->New->Mbed Project?
  3. Is that project available anywhere on github, or other source control system?

Arek - Studio team

Thank you. I found the problem. My enterprise network was getting in the way. If I access KSC then it works as advertised.

1 Like