Mbed forum

Getting started with yotta

yotta

(Guy Willetts) #21

HI I am trying to build the blinky LED example and i get prompted at the build stage to "press enter to continue" and "your browser will open to complete the login". I get a redirect to the yotta repo but never a login prompt or successful login? The process then times out and fails. I installed using the windows msi. Could anyone advise, there is no mention of a login on the tutorial. Thanks!


(James Crosby) #22

@assimilatesystems yotta will also display the URL that it opens on the command line – could you try pasting that into a browser manually, and then see where the browser gets redirected to? You should end up on a page that looks like this, with a URL starting yotta.mbed.com/#login...

If the URL is correct but the page isn't working, please could you confirm which browser and OS you're using, as it's possibly a browser compatibility problem with the website.


(James Crosby) #23

@SamKent We've published updated target descriptions that should work correctly with CMake 3.4 now. yotta update should update you to them automatically the next time you run it.


(文亮 林) #24

@Kojto I am using stm32f411re-nucleo-gcc and follow beginning step. Seems the problem was because the package not ready. Building with frdm-k64f-gcc is ok.


(Guy Willetts) #25

Hi @jamcro01 Yes it works if I paste it in, im using Chrome on windows 10. Thanks for the help


(Martin Kojtal) #26

Are you aware that target is not fully supported yet, therefore there might be failures.


(Sam Kent) #27

@jamcro01 Works perfectly


(Richard Osterloh) #28

Hi @momososo I published that target as a test but it wasn't fully working yet. I'm back on the case now and hopefully will get something going soon.


(Jan Bonn) #29

Hi,

I cannot build the example-mbedos-blinky-beta-release project with st-nucleo-f401re-gcc target . I have these errors:

C:/TEMP/example-mbedos-blinky-beta-release/yotta_modules/ualloc/source/malloc.c:17:31: fatal error: mbed-alloc/ualloc.h: No such file or directory #include "mbed-alloc/ualloc.h"
C:/TEMP/example-mbedos-blinky-beta-release/yotta_modules/ualloc/source/ualloc.c:17:31: fatal error: mbed-alloc/ualloc.h: No such file or directory #include "mbed-alloc/ualloc.h"
C:/TEMP/example-mbedos-blinky-beta-release/yotta_modules/uvisor-lib/source/unsupported.cpp:17:35: fatal error: uvisor-lib/uvisor-lib.h: No such file or directory #include "uvisor-lib/uvisor-lib.h"

It is strange because these files are well present in the module. It seems also that the paths are not propagated correctly. But when I build the same project with the stm32f429i-disco-gcc target it works.

Any idea ?

My configuration:
yotta v0.8.3
cmake 3.4.0-rc1
ninja 1.5.3
arm-none-eabi-gcc 4.9.3 20150529


(Martin Kojtal) #30

@jbbmicro please update your yotta, I have seen the same issue , updating yotta helped, there was a bug , I believe it's in your exact yotta version. Let us know if that helps


(Jan Bonn) #31

I have updated yotta to version 0.8.5 (and also all other components called by yotta have been updated too) but no I have still the same errors.


(James Crosby) #32

@jbbmicro please could you paste the output of yotta target – you'll need the base mbed-gcc target description to be right up to date (0.1.3).

If you could also paste the output of cmake --version that'd provide useful info too.


(Jan Bonn) #33

Hi @jamcro01,

yotta target --> st-nucleo-f401re-gcc 0.1.0
cmake version 3.4.0-rc1

How do I update my target to version 0.1.3? I tried "yotta update" but nothing has changed ?


(Martin Kojtal) #34

Does your target inherit from mbed-gcc? This line does it for frdm-k64f-gcc: https://github.com/ARMmbed/target-frdm-k64f-gcc/blob/master/target.json#L5


(Jan Bonn) #35

In fact I have the st-nucleo-f401re-gcc target v0.1.0 and in this release I don't see such inherit from mbed-gcc.

This is why I would like to use the latest version of this target module but I don't know how to do it ?


(James Crosby) #36

Ah, it seems you are not using an official target. If you wrote the target yourself you can compare it to the K64F target here to see how to inherit from our base mbed-gcc target. There's also the yotta guide to writing targets, which might be useful.

The base mbed-gcc target description includes some logic to make sure things work correctly with different versions of CMake.

Note that as this platform is not currently supported you might run into other problems even after fixing this though!

You can find the list of supported targets at the bottom of this page (currently just the K64F ones).


(Guy Willetts) #37

Are there any supported IDE's available at the moment? Will the MBED classic be used or are we to transition to an offline version if so for either option when are we likely to see them becoming available?


(Dan Ros) #38

Hi, thanks for the question.

The ultimate aim is that mbed OS or yotta will be supported in a very wide collection of IDE's and text editors.

We are currently working on adding support to a couple of third party IDE's, which will hopefully serve as examples for others to add support to their favourite IDE. We hope to be able to share some news about that later this year.

Right now the only supported development mechanism for mbed OS is using the commandline.

Thanks, Dan


(Charlie Tu) #39

Hi all,

I am using STM32F429 Discovery board with using yotta target stm32f429i-disco-gcc. It can work smoothly with the following codes at the bottom (basically same as the one for Freescale)

I do face some issues but mainly because the STLink prefers to Windows. Anyway, finally I can "st-flash write xxx.bin 0x8000000"

============================================

include "mbed/mbed.h"

static void blinky(void) {
static DigitalOut led(LED1);
led = !led;
}
static void blinky2(void) {
static DigitalOut led2(LED2);
led2 = !led2;
}
void app_start(int, char**) {
minar::Scheduler::postCallback(blinky).period(minar::milliseconds(5000));
minar::Scheduler::postCallback(blinky2).period(minar::milliseconds(500));
}


(Romilly Cocking) #40

I just unboxed my new FRDM-K64F and installed yotta on a workstation running linux mint 17.

It took me 22 minutes from unboxing to seeing the blink example running on the board.

Awesome!

Your instructions are very detailed and very clear. Thanks.

I'm looking forward to using this as the Real Time part of a hybrid FDRM/RaspebrryPi-based robot.