Mbed forum

Yotta on raspberry pi 2

yotta
(Josh Grauman) #1

Does anyone know what would be required to get yotta, etc. working to be able to develop on raspberry pi 2 (or similar low priced arm board)? Are there plans for this?

Trying to install Mbed client on Raspberry Pi but getting following errors
(Max Peng) #2

Because yotta is written in python, it could be installed and executed in raspberry pi with Linux.

However, as I know there is no pre-built version of GCC ARM Embedded compiler to build the binary targeting for ARM Cortex-M microprocessors.

(James Crosby) #3

I’ve heard of someone getting it working, but as @mapeng mentions you might have to compile your own compiler! :smile:

(Josh Grauman) #4

Ok, I’ve been working on getting this working on raspberry pi 2. Getting yotta installed wasn’t bad. I even have GCC ARM Embedded “working” (I can run arm-none-eabi-gcc). But I get errors on trying to do a “yotta build.” I don’t think the build system is using all the right directories for includes/libs/etc. When I run yotta build the compiler complains that there is not cstddef file (included from platform.h). If I remember, that was the same error I got on my x86 pc before switching the compiler to the one from the Terry Guo PPA ( https://launchpad.net/~terry.guo/+archive/ubuntu/gcc-arm-embedded). But that PPA doesn’t have a armhf build of the ARM Embedded gcc. Can someone explain what is different about that PPA build? It is supposed to use the same source as the regular ARM Embedded gcc. Any other thoughts?? Thanks so much!!

(James Crosby) #5

I believe it’s because you’re missing the C++ standard library for arm-none-eabi-gcc (or if you do have it, the compiler doesn’t know where to find it).

You might have to compile this for yourself, or it might have been included in your arm-none-eabi-gcc compilation and you just need to move it into the right place.

This issue might include some useful information (though bear in mind it isn’t about cross-compiling)

(Austin Blackstone) #6

here is a blog post on getting mbed client working on the rasberry pi. It uses the Linux yotta target. The instructions include how to install yotta on a RasPi. At the moment there doesn’t seem to be a linux port for Minar, so the examples that use the linux target use linux system calls instead of mbed HAL calls, but I would think its only a matter of time untill someone does a port of Minar to linux so it can work with the mbed hal.