Arm Mbed OS support forum

I got some problems on Mbed Studio

亲爱的先生/女士,我希望你过得愉快,工作愉快。我是苏塞克斯的学生,我们正在学习Mbed操作系统的嵌入式课堂。我发现我们有很多不同之处,Web工作室和Mbed工作室。到目前为止,我已经修改了一些错误。不幸的是,我不明白这个程序错误的原因。错误最多的来自以太网接口文件夹和mbed-rtos文件夹(EthernetInterface - mbed IP library over Ethernet | Mbed](上传://j1xcon83RXiBI9aIKx2WuylCNIW.jpeg)![截屏2021-11-21上午2.52.12|689x500](上传://vSIBe7tmw0yKRo5UgGfsZlTSn9I.jpeg)![截屏2021-11-21 上午2.53.20|689x500](上传://O580yvh5eIdBNn2YS3MaxdgCRo.jpeg)
当我修改这些错误时,它也会生成许多新错误。我真的不知道怎么做。我想我错过了网络工作室,或者我们的PC工作室有一些问题。因为它可以在网站上运行。我希望你能下载这些文件,并在你的电脑上尝试一下。如果你知道这些问题,这是一个正常现象。请告诉我,并告诉我原因。
最好的祝愿,
亲切的问候,
斯蒂芬。

Hello,

there exist also Chinese Forum - Arm Mbed OS support forum. But it is not used much and a chance for a response is lower. Here be so kind and use English.

I tried to translate it via google.

BR, Jan

hello Kamidra
I actually posted in English, but I don’t know why it became Chinese, because I sent the same copy to Mbed service email. Here’s what I posted:

Dear Sir/Madam
I hope you have a good day and good work.
We are learning Mbed OS in our university. I found out that there are a lot of differences between Web studio and Mbed studio on PC. I have modified some bugs until now. Unfortunately, I can’t figure out the reason for this program error. The most errors come from EthernetInterface folder and mbed-rtos folder that I downloaded from our website(EthernetInterface - mbed IP library over Ethernet | Mbed and mbed-rtos - Official mbed Real Time Operating System based on… | Mbed).
There are some errors’ pictures you can see:



when I modify these bugs, it also generate a lot of new bugs. I really don’t know how to do it. I guess there are something different with Web studio I missed or our PC studio have some problems. because it can run on website. I wish you can download these file and try it on your computer. if you know those problems and this is a normally phenomenon. Please let me know and please tell me why.

I don’t know whether the picture uploaded successfully this time. I wish it can be used.

Best wish,
Kind regards,
Stephen.

Hello Stephen,

can you please also share a picture where will be visible whole project folder (without expanded tree) and also the Library panel where will be visible MbedOs version.
Because how I wrote above, the links, what you provide, are obsolete libraries for Mbed2 and are not compatible with Mbed Studio. The Mbed Studio works only with version MbedOS 5.12+, where are EthernetInterface and RTOS already included.

I also see you probably tried something with UDP. If you will share your plan maybe I can recommend something.

BR, Jan

Hello Kamidra
Thanks for your replay. I’m really happy to discuss it with you.
I followed your advice. And I have removed these two folders, the picture as follows:

I’m using Mbed OS 6 now. I have changed my code to the function provided by Mbed OS Libs.

I have 2 K64F development boards. I plan to create a Client-Server program, which can communicate with each clients. I’d be happy to take your advices.

have a nice day,
best regards,
Stephen.