Arm Mbed OS support forum

Error while trying to build example blink program, error is like missing mbed.h file like that

Hello,

I tried to reproduce it.
Mbed Studio 1.4.1 (Windows) > File/New Program… > mbed-os-example-blinky (for MbedOS 6), after import I selected target ARM V2M-MPS3. No errors.
I tried to build it - "argument -m/–mcu: ARM_MPS3 is not a supported MCU."

When you look on the target selector, your target name has a symbol before name (exclamation mark in a circle). When you move mouse on this symbol - > "ARM V2M-MPS3 is not supported with active program’s version of MbedOS"

The issue around "mbed.h". It seems like the MbedOS was corrupted during downloading or something like that. Did you tried to delete the project and create new one again?

BR, Jan

Hi,

Yes, actually i tried downloading 2 times but still showing the same error, can you pls help me with that…i am using mbed studio in ubuntu, not in windows.
Thanks

Sorry, I probably can not help you because I am not Linux user.

Anyway you can try to visit Creating or importing a program and try to import mbed-os-example-blinky but I think the result will be same.
Alternatively you can try to work around it with these steps.

  • Let Mbed Studio in off
  • Create a folder via a system file manager in the workspace where Mbed Studio store projects
  • Download MbedOS - directly from github to your file system, extract it, rename the folder from mbed-os-master to mbed-os and move it to the project folder what you create before.
  • In the project folder create file with name mbed-os.lib and open it like a standart text file. In side this file just place https://github.com/ARMmbed/mbed-os/#9738b27c7df897c29e9769911d6794ba3e5b3f19 and save it. The number is commint number from Releases · ARMmbed/mbed-os (github.com)
  • Run Mbed Studio and select this project and you will see.

However how I wrote in my previous post, I think this is pointless because your target is not supported.

BR, Jan

Hi @bharathhcl,

Apologies for not answering sooner. On Linux Mbed Studio requires libcurl4 package for Git to work correctly. It is mentioned at the end of the installation and in Known issues and troubleshooting - Known issues and troubleshooting | Mbed Studio Documentation .

Please double check that you have it installed correctly on you system. It can be installed using:

sudo apt-get install libcurl4 libcurl4-openssl-dev

Thanks,
Arek - Studio team