Arm Mbed OS support forum

MbedStudio 1.3.1 unusable

Hello @arekzaluski,

I updated MbedStudio (Windows10) to 1.3.1 yesterday. The update itself went well but after I ran the module updates…
The installation of Python tool was stuck on 50% for 2 hours without any progress. Then I closed and reopen the Studio and installation still ran without any progress. I tried it today again and still same.

Because of that I tried to reinstall whole Studio. The installation was completed but the Studio is not able to find any connected target correctly and instead of that only show msg

If I choose No, nothing happen. If Yes, then I am able to set the custom target but still it is not normal. All control icons (build, run and debug) are enabled but when I try to start it then…
msg2

And also…

Fatal Python error: initfsencoding: unable to load the file system codec
ModuleNotFoundError: No module named ‘encodings’
Current thread 0x000058f4 (most recent call first):

I am not able to run anything, Any suggestion?

BR, Jan

Hi Jan,

Thank You for reporting it and happy birthday! I think that you hit the corner case issue that your python tools couldn’t be updated correctly. It was most likely due to Python process for program debugging still running on your system in the background. I recommend restarting your PC and then reinstalling Studio. After uninstalling you can also make sure that mbed-studio-tools folder is fully uninstalled. It will be in ~\AppData\Local\Mbed Studio folder for current user installation.
We will look closer at pyOCD not closing correctly on Windows and will try to fix it.

Thanks,
Arek - Mbed Studio team

Uninstall >> restart >> Install and all seems be correct again.
Thank you for your good wishes and also for support.

Have a nice day
Jan