Install Abandoned


I am currently trying to install the latest version of MBED Studio however the install fails and is abandoned. I have tried everything I can possibly think of to rectify this with no success.

Initially during setup when I am asked to ‘choose installation options’ it states “There is already a per-user installation. (D:\MBED_Studio \Mbed Studio). Will reinstall/update”. This path way and associated directories no longer exist and so it is confusing that it would recognise this pathway.

Following this during the ‘Choose install location’, I has the above pathway preselected, naturally I create a fresh directory to house the install and so the new Destination folder is D:\MBED 1.4.3\ . This however, has no effect and the installation is aborted as “Setup was not completed successfully”, no further information is given.

Things ive tried:

  • Install for this user
  • Install for all users
  • Retried the above as an administrator
  • Used ‘Search this PC’ in file explorer to find any and all association to MBED and/or MBED Studio to delete any associated files
  • Restarted my PC
  • Followed the advice given in this topic: Installation Aborted on Win10 - #4 by arekzaluski
  • Ensure windows is up to date
  • Redownloaded MbedStudio-1.4.3.exe (multiple times)
  • Reinstalling MbedStudio-1.4.2.exe

None of these seem to be successful, at this point I am open to any suggestions as to what maybe the issue and how to rectify it.



I do not know, but just try to using an older version of MbedStudio 1.4.2

BR, Jan

Hi Jan,

Thank you for the link to v1.4.2, unfortunately its the same issue. What ever it is, it seems to be affecting both versions of studio.


Have you searched through the forum for similar issues. I’m sure this has come up before (thinking it was a good while back ) and a remedy was provided.

Hi Andrew,

Finding and removing files manually is not enough. Windows still thinks that Studio is installed on your system as there is an entry in your registry. Can you please check Control Panel -> Programs -> Programs and Features and check if Mbed Studio is listed there? Doing an uninstall from there should remove Studio completely (including Mbed Studio entry in registry).
Please do not hesitate to let me know if Mbed Studio entry is missing. I’ll let you then know how to remove the entry from registry manually.

Arek - Studio team

Hi Arek,

this seem to work thank you, for some general feed back… when uninstalling from the control panel, windows produced a dialogue box stating that Mbed could not be uninstalled as it may have been already, instead it suggested removing it from the program list (which i did). I than attempted to reinstall 1.4.3, it still recognised a pre-existing version quoting the same pathway as above. I continued with the install never the less, updating the pathway and it installed without an issue.

many thanks,