ARMmbed

Installation Error Yotta

Hi:
After several
facilities, the error that yotta.exe and yt.exe files are not installed persists.

The files installed in the directory:

C:\yotta\workspace\Scripts

During
installation, the following errors are detected:

Running setup.py
bdist_wheel for MarkupSafe … error

Running setup.py bdist_wheel
for pyyaml … error

building ‘markupsafe._speedups’ extension

error: [Error 2] El
sistema no puede encontrar el archivo especificado

checking if libyaml is compilable

error: [Error 2] El
sistema no puede encontrar el archivo especificado


Failed building
wheel for pyyaml

Running setup.py
clean for pyyaml

Failed to build MarkupSafe pyyaml

IOError: [Errno 13] Permission denied:
‘c:\yotta\workspace\Lib\site-packages\_cffi_backend.pyd’

What could be the problem?

regards
Carlos

Hey, I too got this problem. Firstly, make sure that you have the admin access to your PC. Secondly, if you have any other version of python already installed on your PC, then maybe uninstall that as yotta installs python too, or while installing yotta, click on cancel when it says that “Do you want to overwrite the existing version of python”. Once you are done installing yotta, just run the “Run Yotta” file and you should be good. Try to compile the “Blinky” sample code. If it compiles well, you are good to go.
Hope this helps.
Thanks
Anuj

Hey,

I have same problem when I am running yotta. I have tried to install yotta again and again the other programs and started again everything and it did not work.

I have python 2.7.10, cmake 3.6.0 and pip 7.0.1 intalled in my computer and I am administrator user in computer.

There is coming errors which i think are connected with pyyaml and libyaml. When I trying to run yotta (I open yotta from Run Yotta -icon) and trying to get the yotta version (I write in comman line: yotta --version) there will come only: ‘yotta’ is not recognized as an internal or external command, operable program or batch file.

What should I do to get this yotta working?

OK. So, I eventully got yotta working on my Windows PC as well as on ubuntu. The steps are:

  1. Download the latest yotta windows installer.
  2. Run the installer.
  3. Click on Run Yotta shortcut on desktop or in start menu to run session with yotta path temporarily pre-pended to system path.

Now, while installing if you are prompted to install python and if you already have python installed, then cancel that part and let the rest of the installation continue. Before running make sure that the path in Environment Variables is correct. Also there will be a Yotta Path and Yotta names in the Environment variables. Befor reinstalling yotta, just delete those two and do a fresh installation.
If this dosent works, try reinstalling yotta and before that install Python 3.5.1 and in yotta installation do not install python 2.7.9.
For ubuntu just follow the steps and it should be done easily.
Hope this helps.

Hey Anuj Dutt,

I did not get working yotta after your advices. When I write to pip install yotta it gives same errors like before:

Failed building wheel for MarkupSafe
Failed building wheel for pyyaml

and in the end
…error code 1 in c:\users…\temp\pip-build-gejigs\MarkupSafe\

But after all https://developer.mbed.org/compiler has been working fine from the start and I can change the device LED light blinky setting and compile to device.

The online compiler uses mbed OS v2.0. Yotta installation is the one that uses mbed v3.0. So, if you are fine working with mbed 2.0 then online compiler is good but if not then we need to figure out something. I have my yotta installation fully working. I am trying to see that what other changes I made to make it work.
I’ll get back to you soon with a fix on this.

Hey. Finally I got it working.
So the steps are:

  1. Download yotta installer. Ref.: http://yottadocs.mbed.com/#installing-on-windows
  2. Install all features except mbed-serial for now.
  3. Install python that comes with that.
  4. Open Environment variables in windows.
  5. In “YOTTA_PATH”, put path of all files that you have in your yotta folder. example:

C:\yotta;C:\yotta\gcc\bin;C:\yotta\python;C:\yotta\python\Scripts;C:\yotta\cmake-3.4.0-rc3-win32-x86\bin

6.In “YOTTA_INSTALL_PATH” , put:

C:\yotta if your yotta folder is in C

7.In “PATH” append it as:

C:\yotta\mercurial;C:\yotta\python;C:\yotta and so on.

8.Now refresh and click on “RUN YOTTA” shortcut formed on your screen. It works.

I confirmed the steps by installing yotta 3-4 times. It works every time :slight_smile:
I’ll soon post a video of all the steps on youtube.com. Hope this helps.

1 Like

Hey Anuj Dutt,

the first of all. Very big thanks to your job and thank you for using your time to my little problem! Now it works! :slight_smile:

I think there was a problem in “YOTTA_INSTALL_PATH” where was just C:\yotta -path. When I followed this steps the Run Yotta shows right after opening it this:

C:\Windows\system32
‘C:\yotta\mercurial’ is not recognized as an internal or external comman, operable program or batch file.

But it did not bother at all using “pip install yotta” command and it was installing perfectly yotta version 0.16.4.

Very big thanks again!

You are most Welcome :slight_smile: I am glad that now we know the workaround of how to make it work.
Happy to help :slight_smile:

Hello:
I have yotta installed on two PCs, one with Windows 7 SP1, and on the other have Windows 8.1. Doing well in the first and second get the following message:
“Yotta is not recognized as an internal or external command”.
Check the path environment variable as a user and as an administrator, and agree completely. As recommended Anujd9
I’m confused, I can do?
Carlos

Hey, I am facing the same issue
C:\ yotta is not recognized as an internal or external command,
I am unable to fix this with the above steps. Please help.

Ok. So you have pip installed? check that for once and update pip if possible using pip install -U pip
Secondly, you need to be the admin of the system. Thirdly, you need to run " yotta init " in the run yotta terminal and not the command prompt.
If the problem still persists, can you provide the image of the environment variables that you have entered ??

This post is really good I also facing the same situation when I tried to install Yotta my system does not support also shows an error dell error code 2000-0333, so I really want a proper solution how to remove this error as soon as possible.