Arm Mbed OS support forum

Keep getting "Internal Error" message

I keep getting Internal Error upon compiling on Internet Explorer, Firefox & Google Chrome. Mbed ver 1.10.25.0

Compiling my program for FRDM-K64F. Using Mbed library 164.

Me too. I’ve tried with Firefox and Chrome. I’m also using Mbed online version 1.10.25.0, but compiling for LPC1768 MBED board.

me too…deleted few things with libraries imported into them thinking it was a dodgy file, cant get running or debugging programmes i need to work at either using mbed lpc1768.

Same problem here. Unable to compile and download the .bin file.

Keep getting “Internal error”.

same here. compiler is either stuck “preparing” of stops with an “internal error”

me too. from yesterday evening I cannot work. online compiler started to be annoying.

Mbed Studio (offline) is working fine, you can import your programs if you commit and publish them using Mbed-online, that function is still working.

Might be an idea to try that now seeing that you can’t online compile anyway.
Gives you a chance to get used to the new Studio-Online that will replace the classic Mbed-Online, its almost identical in layout and function but loads more options.
But will continue to have the internet connection problem as with all online systems.

I use both Studio-offline and Mbed-online just in case of internet/Mbed-compiler issues.

Would love to use Studio offline (just tried it again with this current outage) but can never get it to work - seems to not find files down my own Apppath. I read forum posts on this previously but can’t remember the fix - possibly because there’s a %20 space in my computer name.

Is “commit” and “publish” the only way to get projects into Studio? Fortunately I’d done an export (all repositories) just an hour or two before but, even without trying to compile, Studio doesn’t recognise it as a project.

How long do these outages often last?

This issue is happening to me as well… not really happy, since I need to work on my semestral project. Guess I’ll try out Studio offline…

I tried all the options in Mbed studio, still I couldn’t get it working. Even example mbed-os blinky project I couldnt get working.
Unknown type name’DigitalOut’
and other [cpp] erros comes up.

Any idea??

cheers

Update: The Online Compiler build service is now back up and running thanks to @SamCHogg. You should find that your projects compile again. For those of you who’ve lost source code, we’ll try to preserve our backups until Monday.

Apologies again for the disruption!

Hi,

All builds are failing using the Online Compiler as of Friday night (UK time). We’re not likely to have it fixed until Monday unfortunately.

Apologies for the timing of this, and appreciate that it’s frustrating.

If your work is urgent, then we have Mbed Studio and Mbed CLI as a workaround. The newest version of Mbed Studio, which you can download from os.mbed.com/studio also ships Mbed CLI and other command line tools that you can access through the terminal. N.B. Mbed OS 5.12+ is supported due to the compiler we ship with Studio.

Kind regards,
Joe

We’ve not had a significant outage like this for a while and had close to 100% uptime so far this year. Usually we’d be able to fix it quickly but there’s no one available this weekend unfortunately.

Thankyou JoeA for keeping us up to date, and for the quick fix. Damn you - I was planning on having a Saturday/Sunday off and do some normal-person things. Look like it’s back to geek mode :frowning:

1 Like

Hi JoeA. If we did lose files, what is the process for requesting you guys to back them up?

Same here

Hi, you can email support@mbed.org and let our team know the following information:

  • Your Mbed username
  • The name of your program
  • Roughly when you experienced this issue (it will have happened when you clicked “compile”)

They will then attempt to recover your code as close as possible to the point where you lost it.

Thanks,
Joe

Hi!!
I keep getting Internal Error suddenly!!
May I do something or just wait?
Thanks in advance