Mbed serial port is not detected in Windows 10

When I connect mbed board (LPC1768) to my laptop, the serial port is not detected. I have windows 10.


Maybe this will help you - Mbed serial port is not detected in Windows 10

BR, Jan

As far as I know there is no driver for mbed LPC1768 microcontroller. I use this microcontroller with my desktop that is an older computer with Windows 10 and the serial port is detected. I never installed a driver on my desktop. However, the serial port is not detected with my laptop that is a newer computer with Windows 10.

Sorry, I place wrong link - Solved: Re: LS1046ARDB serial port not recognized on Windo… - NXP Community
Are the rest functionality working?

BR, Jan

Hi Johnny,

Following the link youve shared, it would seem i need to update the bootloader however i am not sure which image i would need for the mbed lpc 1768. Would you be able to help?


latest was always shared here - Firmware LPC1768 LPC11U24 - Handbook | Mbed

But, If you want to have LPC1768 compatible with KeilStudioCoud then follow this topic - New beta firmware for LPC1768 - Keil Studio - Arm Mbed OS support forum

BR, Jan


I’ve update the LPC’s firmware and I am able to run programs using mbed studio with out issue. However, I’ve noticed that windows still doesn’t recognise the device, nor does serial monitor communicate with the device. Additionally, I’ve tried using terminal emulation software such as CoolTerm and the LPC is not detected when scanning serial ports and thus won’t communicate with the PC. For reference I’ve used the nucleo l476rg and that communicates without issues.

Just for sure, you checked the Windows device manager and there you see unrecognized device right?

BR, Jan

That’s right, it’s either an unrecognised usb device or a storage device. But never recognised Comms device

I do not want to say that your board is broken, because I can not know that. So sorry, I am out of ideas.

BR, Jan

Not to worry, thank you for your help. If any thing changes or I get some new information to share I’ll let you know!


As a little update; Ive recently changed the motherboard of my PC which seems to of fixed the serial issue with the 1768 on my personal computer. However, Ive found that when I connect it to other PC’s and laptops the device appears under “Portable Devices” rather than “Ports (COM & LPT)”. I am not sure how/or what to change to enable windows to view the connection as a COMMS connection rather than a portable device? Ive had a look at the windows serial driver that mbed suggests to read however it seems unhelpful as the windows version is newer than 7 and the download for the installer doesnt seem to commence.

I checked the device properties and under the “Driver” tab it gives the driver version as 6.1.7600.16385 dated 06/2006 with the driver provider as Microsoft.

1 Like

After further investigation I may of found a work around.

As previously stated, the serial program I made runs without issue on my PC however, if i then use a different PC/laptop the serial communications fail. On the other PC, I inspected the driver details for the LPC1768 which showed:

driver version as 6.1.7600.16385 dated 06/2006 with the driver provider as Microsoft

Following Jan’s link I again updated the firmware of the LPC1768, which I didn’t feel necessary as it was already upto date. Never the less I did it again. Surprisingly It worked. Upon inspecting the driver details again, I found that the windows driver had updated and now showed:

driver version as 10.0.19041.746 dated 06/2006 with the driver provider as Microsoft

It would seem that the firmware update also updates the windows driver though this would suggest that with the use of each new PC/Laptop you will need to carry out the firmware update again and again to update the driver regardless if your using the same LPC device. Which means that as I am using the LPC as a microcontroller for a group project, I will have to “update the firmware” for the LPC using each of the 4 laptops so that serial will work on those machines.

This is a little fustrating as I would of expected the relevant windows drivers to be updated when carrying out actions such as updating MBED studios, or even installing/re-installing studios. I will be meeting with my group again over the following week and I will update this comment after doing so with the results.


That does not make sense. I believe Windows already contains both drivers. The driver was probably changed by Windows itself in context of changes (made by firmware update) in the device.

If you will have this issue on another PC, then try to change the driver manually to same one.

BR, Jan