I have the same problem. I started Mbed studio and tried running the mbed-os-example-blinky. I used the NUCLEO-F401Re board, which is recognised by MBED studio. However, I cannot expand the mbed-os-example-blinky in the workspace. A rotation sign appears.

Also, the blue tab at the bottom turns from blue - online to yellow-offline. After that, nothing happens. If I log out of MBED Studio, I cannot log-in. When I shut down Mbed Studio, an error message " A JavaScript error occured in the main process
Uncaught Exception
Error: kill ESRCH
at process.kill(internal/process/per_thread.js:189;13)
…with sub-errors pops out.

I tried reinstalling MBED Studio, but the problem remains.


why do you post this in MbedOS section? When you have a problem with Mbed Studio.

Try to uninstall Mbed Studio, then check folder ~\AppData\Local\Mbed Studio and delete the rest. Then restart PC and run installation again.

BR, Jan

Hi @siva_periasamy,

Would you mind providing few additional information? It will help us in investigation.

  1. What operating system are you on?
  2. Does the disconnection happen only when you have a NUCLEO-F401RE device connected to the PC or also when it is not connected?

Arek - Studio team

Hi Jan

Your suggestion worked. Thanks.

Hi Dan, Arek

I came back to the MBED after a break. The problem occurs again. I can uninstall and reinstall as per Dan’s instruction, but in the long term, this is not sustainable. Any suggestions?