Printf problem SiLabs STK

Hi,

With mbed OS 5, it seems the silicon labs kits have problems with printf. Tested this with one of the inbuilt examples and just adding a printf command. The program worked fine, but no output on the serial line.

This worked just fine before mbed OS 5.

Ps: tried this on a happy gecko.

Hi,

So the happy Gecko is not yet supported in mbed OS V5, the perl geko is. See here for full list of supported boards: https://developer.mbed.org/platforms/?mbed-os=19

-Austin

Thanks for the reply, I didn’t know that.

Is there a simple way to tell the online IDE that I want to use mbed OS 2 then?

The online compiler can do both mbed 2.0 and mbed 5.0. The difference is

2.0 = mbed SDK + mbed RTOS (external library)
5.0 = mbed OS (mbed SDK and RTOS inside mbedOS)

to use one or the other simply change your mbed library to either be the mbed 2 library or the mbed 5 library.

For ease of use here are the direct links that you can import from inside the online compiler:
mbed OS : https://github.com/armmbed/mbed-os
mbed 2.0 SDK : https://developer.mbed.org/users/mbed_official/code/mbed/

PS: mbed OS 2.0 is not a valid term.

-Austin

Thanks again for the help. I will try this directly tomorrow.

However, if this is the reason for the problem, why would the examples for the happy gecko automatically import the mbed 5 library and not the mbed 2 one?

Good point, they shouldn’t. I suspect you are in fact using the mbed 2.0 SDK and there is now a problem. Please double check and then report the issue along with a reproducable test case to github.com/mbedmicro/mbed/issues .

-Austin

I will do that. If this is the case, is it possible to use an older version of the mbed 2 lib? How?

I now verified that the programs use mbed 2.0, but the error remains. I reported an issue (#2791) as you suggested.

In the meantime, do you know how to revert to an older version of the mbed 2.0 library. I use the platform in education and it would be great if I could at least find a workaround as soon as possible.