Still trying to import original program

Still trying to pull in the Apple remote control Program. It will not load up into mbed studio. I’ve deleted he mbed library in the program folder and then tried to import OS5 using the provided github link but get the following message


I subsequently selected ‘program’ in the above dialog box after deleting the old version of mbed. The program folder now has mbed-os listed where mbed used to be listed before. It compiles but throws up an error because I have not used the bare metal profile. I decided to do that in mbed studio, but when I try to import it into mbed studio I get this error

I think I’ve found the problem, but I dont know how to fix it. When I commit and publish this program

it somehow gets renamed to this one (highlighted)

I know this because when I subsequently go to the programs home page, I’m not getting ‘AppleRemoteController’ in the address line but ‘RC5_AndrewR’.

So I’ve got the wrong program, and its not being recognised as a valid program in mbed studio.

I’ve tried renaming the file but the issue persists (I’ve commited and published the program). The file url is referring to te yellow circled file and mbed studio doesn’t recognize the program as valid.

Any ideas?

MbedStudio can not recognize this program (RC5_AndrewR) because it is not MbedOS5 or 6 valid program, it is Mbed2 program. Mbed Studio does not support Mbed2, only Keil Studio Cloud does this, how I remember.

BR, Jan

I’m not trying to import that program Jan. I’m trying to import Apple_Remote which has been updated to mbed-os. When I copy the url and paste it into the Mbed Studio ‘Import Program’ dialog box, it spins for a few seconds and then I see it is pointing to ‘RC5_AndrewR’ and not Apple Remote. I believe Mbed Studio may be rejecting this as a valid program because its trying to pull in Rc5_AndrewR which has not been updated to mbed-os. But, that’s not the program I’m trying to pull in.

So, I don’t know how to take this forward. I renamed Apple Remote and the RC5codes.h file and recompiled, committed and published, but it still points to RC5_AndrewR.

Very frustrating.

Ok, when I am looking to your tree above. The AppleRemoteController_copy is the main project folder name, inside of that folder you have AppleRemoteController marked as library folder and whole program is inside this library, that is wrong.
From my point of view you need open the library folder AppleRemoteController and cut out whole content of that folder and paste it to the project folder AppleRemoteController_copy. Then re-publish the project and then import the program AppleRemoteController_copy to MbedStudio.

BR, Jan

Thanks Jan - I will try that in the morning.

BR Andrew

Success! I have imported the program into the Keil Studio

Thankyou Jan

You’re welcome, I glad I could help you.

BR, Jan