Arm Mbed OS support forum

UBLOX_C027" is not recognized

Hello all,

I updated my mbed-os library to new mbed-os 5 library, because it has the new versuin of the LWIP library but I faced this issue:
Error: Target “UBLOX_C027” is not recognized

Ublox-C-027 is not supported in the new mbed-os???

Please help

Regards
Nada

Hello,

Ublox targets are not supported in the MbedOS6+, latest version where was your target supported is MbedOS5.15.5.
You can verify that here. You will not found combination of MbedOS 6 and Ublox targets.

BR, Jan

Thank you Johnny for your help.

I want to ask you if I can import this version directly or I have to go back to the old revision.?

and If I have to do so, could you please tell me which one?

Thank you in advance.

Regards
Nada

Hello Nada,

I do not know what tool you use but for the Oline compiler

BR, Jan

Thank you Johny for your support.

I really appreciete it

Dear Johnny,

How can I change in the mbed os library files
image

Everytime I tried to open one file, I faced this error: documentation path not found. I tried to export the program to my laptop and change the file but when I want again to upload the file to the online compiler, I’m facing an error: zip file empty.

How can I change the files in the library online?

Regards

How can I change any file online

Hello Nada,

The tree what you see on your picture is only Doxygen documentation. And I am sure that is not possible with Online compiler directly.

  • I not tried it, but I think, you need to fork the MbedOS from https://github.com/ARMmbed/mbed-os to your own repository, edit it and then use it.
  • If you have access to Mbed Studio online Beta, it is possible with it.
  • Else you need to switch to a offline tool (Mbed Cli, MbedStudio and so on). That is probably simplest way.

BR, Jan

Hi Johnny,

Thank you so much for your quick reply and support. I managed to do my changes. I already import the new version and then switch to mbed os 5.15.6 version.

But I want to ask you a question please, Do you have any idea how to activate the Vlan on mbed. I know that I have to assign 1 to ETHARP_SUPPORT_VLAN 1 inOPt.h file
/**

  • ETHARP_SUPPORT_VLAN==1: support receiving and sending ethernet packets with
  • VLAN header. See the description of LWIP_HOOK_VLAN_CHECK and
  • LWIP_HOOK_VLAN_SET hooks to check/set VLAN headers.
  • Additionally, you can define ETHARP_VLAN_CHECK to an u16_t VLAN ID to check.
  • If ETHARP_VLAN_CHECK is defined, only VLAN-traffic for this VLAN is accepted.
  • If ETHARP_VLAN_CHECK is not defined, all traffic is accepted.
  • Alternatively, define a function/define ETHARP_VLAN_CHECK_FN(eth_hdr, vlan)
  • that returns 1 to accept a packet or 0 to drop a packet.
    */

but how can I handle the other callbacks
LWIP_HOOK_VLAN_CHECK and

  • LWIP_HOOK_VLAN_SET hooks .

I’m trying for weeks and I didn’t find many information mentioned about that.

If you have any idea or any example I will be apprecieted even if it’s whith the LPC1768.

Regards
Nada

Hi Nada,

I would like to help but I don’t know anything about that, sorry.

BR, Jan

Thank you so much Johnny, You helped me alot.

Regards
Nada