Arm Mbed and Pelion Device Management support forum

When using mbed-pelion-example - Device is not registered in Pelion Device Management

Hi,

Sorry if my request seems a bit stupid but i cant find a solution to my problem.

I am a using a custom board that is very similar to the Seeed Arch Max board that has a mbed-pelion-example available https://www.pelion.com/docs/device-management/current/connecting/tutorial-pelion-mbedos.html.

When running the application i get the following output printed to my serial output:

On the Pelion Device Management platform, my device is not listed in the device directory.

I am using DHCP and can ping my device. When using the TLS example application the connection to a HTTPS website works. When i look on my SD card all KV store files are present.

I tried to reconfig the certificates but it still doesn’t work.

Can anybody help me ?

Thanks in advance.

Hi @jorisdonkers and welcome to the community.

Can you please specify which board are you using? Further, try to see if this workaround described here from a recently reported issue, can fix the problem you are facing.

Hope that helps,

Hi Cvasilak,

I am using a custom made board. It uses the STM32F407VET6 controller. All very similar to the Seeed Arch Max board as mentioned in my previous post.

I tried doing the mass erase as mentioned in the link you sent me but it did not solve my problem.

PS C:\Users\nljdonk\mbed-os\mbed-os> pyocd erase --mass-erase
0000651:WARNING:board:Generic ‘cortex_m’ target type is selected; is this intentional? You will be able to debug but not program flash. To set the target type use the ‘–target’ argument or ‘target_override’ option. Use ‘pyocd list --targets’ to see available targets types.
0000832:INFO:eraser:Mass erasing device…
0000834:INFO:eraser:Erasing chip…
0000835:INFO:eraser:Done
0000835:INFO:eraser:Successfully erased.

I also noticed, the first time after i formatted my SD card, initializing littlefilesystem gives the following error:

lfs error:494: Corrupted dir pair at 0 1
lfs error:2222: Invalid superblock at 0 1

After a reboot, the error is resolved.

Thanks for the fast reply. Are there some other things you know of that i can try?

Thanks in advance.

Hi @jorisdonkers,

I’ll suggest enabling debugging trace to see if it gives you some more information. Check our documentation page for information on how to enable this.

Further, try to use a different SD card if you can in case something is corrupted…

Hope that helps

Hi @cvasilak,

When enabling the debugging trace, the program gets to big for the flash:

Link: mbed-os
c:/program files (x86)/gnu tools arm embedded/6 2017-q2-update/bin/…/lib/gcc/arm-none-eabi/6.3.1/…/…/…/…/arm-none-eabi/bin/ld.exe: ./BUILD/ARCH_MAX/GCC_ARM/mbed-os_application.elf section .text' will not fit in region FLASH’
c:/program files (x86)/gnu tools arm embedded/6 2017-q2-update/bin/…/lib/gcc/arm-none-eabi/6.3.1/…/…/…/…/arm-none-eabi/bin/ld.exe: region `FLASH’ overflowed by 39472 bytes
collect2.exe: error: ld returned 1 exit status

Trying a different SD card did not work.

Thanks for all the help.

Hi @jorisdonkers - the flash size grows due to the large amount of trace strings. You can cut down on them by setting the trace level to a lower level, please see mbed-trace repo: https://github.com/ARMmbed/mbed-trace#tracing-level