Flashing failed in keil studio cloud for Toshiba board TMPM4NR

Dear Mbed Team,

We are facing an issue while flashing mbed-os-example-blinky binary to the Toshiba board TMPM4NR in Keil Studio Cloud using Daplink webusb though build is successful. We have observed the error “Failed to run program” while flashing as shown in the below diagram.

Selected the “Use Daplink” option in File > Settings > Open Preferences > Run category before flashing as TMPM4NR is Mbed enabled board.

Test environment:

  • Sample code : mbed-os-example-blinky
  • mbed-os version : 6.17
  • Target board : AdBun-M4NR development board
  • Debugger : Daplink V0254
  • Keil Studio Cloud version : 1.6.0

Could you kindly provide instructions on how to flash binary to the TMPM4NR board and enable debug option for the same board.


Hi @Deepak_Shreshthi,

Have you tried to deselect Use Daplink option? CMSIS-DAP will be used then to flash the board. I don’t see this board officially added to GitHub - ARMmbed/DAPLink yet so not sure how compatible the firmware on this board is with webUSB feature used by Keil Studio Cloud.

Arek - Studio team

Hi Arek,

Have you tried to deselect Use Daplink option?

We have tried this, but the observation is same. Observed the error “Failed to run program”.

We are able to flash and debug another Toshiba board TMPM4G9 on Keil studio cloud with Daplink option.

I don’t see this board officially added to GitHub - ARMmbed/DAPLink

Yes. It is not officially added to Daplink github.

One more observation is that two weeks ago, we were able to flash binary to TMPM4NR board on keil studio cloud using daplink webusb on keil studio cloud version 1.5.x, although debugging was not working.


Hi @Deepak_Shreshthi,

Are you using the Chrome browser to run KSC? If so can you try the following…

  1. At the left of the Chrome address bar is the View site information button (represented by the Padlock icon).

  2. With KSC open when you press this button it lists the configured USB device(s) and Serial port(s).

  3. Revoke access to them using the x button in this list.

  4. Then to apply these changes Chrome mentions to reload this page. Press the Reload button to reload KSC.

  5. Once KSC has reopened select the ‘Connected device’ UI in the Explorer panel which will then switch to the Device Manager panel.

  6. Then with your AdBun-M4NR development board connected to your system use the Add Device button to reconnect your board.

  7. Now try the Run operation again.

Does this operation still fail and the notification mention “No device selected”?

Kanthan - Studio team

Hi @kanpah01 ,

Thank you very much for your support.
We have successfully flashed the binary onto the M4NR board using Keil Studio Cloud version 1.6.4. However, we are currently unable to enable debug mode for the M4NR board.
Could you please help us in resolving this issue?