KSC upload wrong binary

Hello KSC team,

I faced an issue with uploading binary to Nucleo-H743ZI2 via Play button (Run project) of KSC.
First I had an example with MbedOS 6.16 with console output

(>>) Running on Mbed OS 6.16.0.

Then I change the MbedOs version to MbedOS 9.6. New compilation of MbedOS and so on… Then was expected to see 6.9 in console output, but reality is different

(>>) Running on Mbed OS 6.16.0.

Only when I used the simple Hammer button (Build) and manually upload the binary to the board, then I see expected output 6.9. However how I hit the Play button again, then it is back to 6.16…

That seems like the Play button use different binary file than the correct one.

  • Re-activate same project does not help
  • Activate another project and back the previous one also does not help
  • Reload page does not help
  • Close and reopen page does not help
  • Clean build does not help
  • after aprox 30 compilation → Failed to run program: Unable to locate debug binary. Please refer to the documentation But that tell me nothing because I change nothing and it worked 30times before. New clean project does not solve this, but update MbedOS back to 6.16 make it working gain :smiley:

BTW the conslole output come from


BR, Jan

Hi Jan,

Apologies for the delay in responding to your query.

Are you still encountering this issue in KSC?

I tried to reproduce this issue on two different systems using KSC v1.5.50 but it is working correctly for me …

(1) on macOS Monterey v12.6 with Chrome browser I created a new mbed project using the Sockets example from the supplied Mbed OS 6 projects and then connected up FRDM-K64F via Web USB. Next the main() in main.cpp was updated with the mbed version printf statement. Then run operation (Play button) was performed. As part of the run operation it performed a clean build followed by the deploy to device. The Serial Monitor (console output in KSC) reported Mbed OS 6.13.0. Now I changed the Mbed OS version to 6.9.0 using the Mbed Libraries panel. The run operation was performed again (it performed clean build & deploy). The Serial Monitor updated to report Mbed OS 6.9.0

The preference settings used:

  • Debug > Connect Mode = haltOnConnect
  • Run > Erase Mode = sectors
  • Run > Program Flash = on
  • Run > Reset Run = on
  • Run > Use Daplink = off (or on)
  • Run > Verify Flash = on

(2) on Win10 with Edge browser and NUCLEO-F429ZI connected I carried out the same procedure as mentioned in (1) however this time I used PuTTY for the console output. Again PuTTY updated to report the correct updated Mbed OS version.

The preference settings used:

  • Debug > Connect Mode = underReset
  • Run > Erase Mode = sectors
  • Run > Program Flash = on
  • Run > Reset Run = on
  • Run > Use Daplink = off
  • Run > Verify Flash = on

If this is still occurring for you can you please try with the Socket example that is supplied with KSC and a different board if you have one to see if you get the same behaviour as before.


Hello Kenthan,

The problem was “gone” the next day. However, this issue is not stable and I can not found any step by step cookbook how to reproduce it. I faced this/similar behavior few times in the past (with different releases of KSC).
I do not expect you find it and solve it right now, but hope that info will help you in future.
Your settings are default except Connect Mode. I have it also set to underReset because of STM32 targets.

Thank you for the response.

BR, Jan