Mbed forum

mBed CLI with Arch BLE


(Tim H) #1

I have an old Arch BLE lying around that I thought I would use for a project. mBed has changed tools yet again, and I thought I would try the new mBed CLI. The online IDE is ok but nobody serious wants to use an online IDE.

Anyway, I updated the firmware to Daplink. That actually went perfectly smoothly the first time. Good job there!

Next I installed the mBed CLI. You guys obviously didn’t learn the lessons of Yotta and ditch Python, so it seems to be super slow but whatever. If it works well I’ll live with it. I created a new mBed OS 5 program and tried to list the targets but I only ever see this:

[mbed] Detected ARCH_BLE, port COM3, mounted D:, interface version 0251:
[mbed] Supported toolchains for ARCH_BLE
| Target | mbed OS 2 | mbed OS 5 | ARM | GCC_ARM | IAR |
|--------|-----------|-----------|-----|---------|-----|
Supported targets: 0

I figured - hey it’s pretty much an nRF51-DK, so I tried compiling for that instead but ran into an issue with obj-copy not liking 64-bit values or something. A little googling reveals that the latest version of the GNU ARM Embedded compiler is broken. Fine I installed an older version.

Finally I get a .hex file. I copy it to the Arch BLE and it seems to copy across ok but does not actually work. Ok I guess that is reasonable since actually I think the nRF51-DK has 32K of memory, not 16K. And it has a crystal whereas the Arch BLE doesn’t. Eventually I find platforms.json and try just editing releases: [2] to releases: [2, 5]. It starts to work but gives me a compilation error (some header to do with OTA stuff not found). Ok maybe it really doesn’t work with mBed OS 5 - OTA might need 32 kB of memory.

So I start again with an mBed OS 2 project. This time however I still get Supported targets: 0, and after reading through the mbed python source (yeay who doesn’t love debugging by reading source code) I eventually realise it is because there is simply no ARCH_BLE target in the targets matrix (mbed detect -S). Wtf? It was there when I was using mBed OS 5!!

What is going on? Is it impossible to use this board any more?