Arm Mbed OS support forum

MTB_MURATA_ABZ for mbed os6

Hello everyone,
I understand that support for this board is no longer available for mbed os 6. However, with the ability to import custom boards, i figured i could work around it that way. So I have been trying to get the board to boot up properly but i havent had any luck. So far this is how my custom json file looks

and i used the same peripheral pins.c, pinnames.h, and peripherialname.h files from the MTB_MURATA_ABZ files back when it was still supported.
murata

files listed down below the link. This was the old version of mbed that I was using that was working .

Currently, now that i upgraded , as i compile and run the code, I run in the file stm_spi_api.c, in this line
static void _spi_init_direct(spi_t *obj, const spi_pinmap_t *pinmap)
#endif
{
struct spi_s *spiobj = SPI_S(obj);
SPI_HandleTypeDef *handle = &(spiobj->handle);

spiobj->spi = (SPIName)pinmap->peripheral;
MBED_ASSERT(spiobj->spi != (SPIName)NC);

it fails here in this assert. As long as the pin configuration is set up correctly, which it should since I am using the previous pin configuration from this board and it has worked before in the previous version of mbed before mbed os6, what could possibly be the issue? I double checked pins which should be correct.

Is the module powered by a STM32L082? If so then you should change the inherits line to match.