STM32F401RE Nucleo-64 board - FAIL.TXT - Storage is only 12kB available out of 32kB size

I’ve just started working with the STM32F401RE Nucleo-64 board.
This morning I tried to load a very simple program to turn on a LED, but these messages appeared:
“low-level connection failed on first attempt, device may be in a low power mode” and “mbed2-example-blinky failed to run. Please refer to the documentation”.
The same program with the same cable does not create problems with my other board STM32F401RE .
I thank in advance whoever will help me because I have an exam soon.


be sure both boards have ST-link firmware up to date and try perform full MCU chip erase via STM32CubeProgrammer.
If this is a new project, then is recommended to use Mbed OS 6+ instead of obsolete Mbed2.

BR, Jan

Hi! I’ve just noticed that in the problematic board the total capacity shown is of only 32Kb instead of 1,52MB.
Moreover in the NOD_F401RE (D:) appears a FAIL text document with the line “the interface firmware FAILED to reset/halt the target MCU”. Since I’m not an expert, could you please explain me step by step how to solve this bug?
Is it possible to reset the board to the factory version?

If you see in your system that the onboard memory is just so low, then it seems your MCU is really not powered or dead.

Try to compare states of power leds and jumper settings with OK board.

BR, Jan

The jumpers are on the same position as the OK board. LD3 and LD1 are red.
Someone had a similar problem as explained here: only 12.0KB see storage | Mbed

I’ve just tried to close boot0 pin to pin + 3.3V, before connecting Nucleo to a PC, but nothing.
Do you suggest me to buy a new board? I honesty think this is a solvable problem, so it’ll be a pity to throw the board :frowning:

You can try to measure MCU’s VDD pin if is powered or not.
Also how I wrote above try to connect the MCU via STM32CubeProgrammer (with settings - under reset) and performe chull chip arese if it will be possible. If not I do not know what more you can do.

BR, Jan

How can I perform full MCU chip erase via STM32CubeProgrammer? Sorry, I’ve never done that.
I’m verifing the VDD with a multimeter, I’ll let you know in a short while

VDD (the PIN above BOOT0) supplies 3.3V

After successful connection to the board via green Connect button, just hit the school rubber icon (down left).

BR, Jan

This is my attempt:

Is there something I could do further?

On right panel set:

  • Mode - Under reset
  • Reset mode - hardware reset

If this will not help, then I am out of ideas.

What you did:

  • The cable is OK because it works with another board and the STM32CubeProgrammer has a communication with ST-Link
  • MCU is powered (measured)
  • Position of jumpers were checked and compared with a working one
  • ST-link firmware is up to date

BR, Jan

I’ve tried to upgrade once again the firmware and that seemed to work properly (no error warnings to be seen). Then I followed your indications:

Thanks a lot for your time Jan!
(I think I’ll change my board, but, if anyone else has solved this bug before, please let us know)